summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-03-09 14:35:37 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-03-09 14:35:48 +0100
commit3901edd0d4c7902f33ba7b3defa3e6e79a52bbb7 (patch)
treebad6f14a971e66596c0a68a7dd459d50094c70c1 /sys-libs/libomp
parentsys-devel/llvm: use system six for lldb (diff)
downloadgentoo-3901edd0d4c7902f33ba7b3defa3e6e79a52bbb7.tar.gz
gentoo-3901edd0d4c7902f33ba7b3defa3e6e79a52bbb7.tar.bz2
gentoo-3901edd0d4c7902f33ba7b3defa3e6e79a52bbb7.zip
sys-libs/libomp: version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-libs/libomp')
-rw-r--r--sys-libs/libomp/Manifest1
-rw-r--r--sys-libs/libomp/libomp-3.8.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-libs/libomp/Manifest b/sys-libs/libomp/Manifest
index 008be44fa11f..26fba9cb13bc 100644
--- a/sys-libs/libomp/Manifest
+++ b/sys-libs/libomp/Manifest
@@ -1,2 +1,3 @@
DIST openmp-3.7.0.src.tar.xz 2251108 SHA256 8d8a224e5689596a35652fda87e4be29853c4b85fbc7a6562019badfad779f2a SHA512 70862733fbfe934cb676291d21855b4b52dfb8d5a38690551bc623777381f9fec2a567bc6f55d7122a3be862d170ac1abd6fe0e95e334006469e8c11f28d4402 WHIRLPOOL 432732b64b3ba5570f6914fcfed11813524350cce3096dae885d73579bae5cd85ea64ec51405b64adab6ff72b2c835ef639c0f14b7652defdfb8510dbd3b072b
DIST openmp-3.7.1.src.tar.xz 2026988 SHA256 9a702e20c247014f6de8c45b738c6ea586eca0559304520f565ac9a7cba4bf9a SHA512 ec29f2665c9de4dee184f86a980a90c87a99e7728bb9c46c9e513801c30b28b6496bfcfbe4cefbd90ef63b761886cd74c19cf8e26a8854d8569e357b78633f6a WHIRLPOOL e69f2ef825df7f438db3647d2405d0fe6e6b00d8614efe0783e1fef5ae72db11b4a5f231383f3cc66402cb0785a025610187cc69fba2edbafa51136bd990453e
+DIST openmp-3.8.0.src.tar.xz 2233144 SHA256 92510e3f62e3de955e3a0b6708cebee1ca344d92fb02369cba5fdd5c68f773a0 SHA512 46d5a87855237308d1df36fa2c0a22a26b682e2db21ef804c5ba805e0e700fa89473ec3178195a932bf9cb53179c155f4048a036ff566165822a274cbb6302a4 WHIRLPOOL c5ffb78ce3f94b837ecd349637d19bcfaef589553e3708c651822042eb25abef81639e0a7d6c221bb15942d24f4ee5ed5431f170b763b09bfd471a391646df5e
diff --git a/sys-libs/libomp/libomp-3.8.0.ebuild b/sys-libs/libomp/libomp-3.8.0.ebuild
new file mode 100644
index 000000000000..a35930ccf9ba
--- /dev/null
+++ b/sys-libs/libomp/libomp-3.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-utils multilib-minimal
+
+MY_P=openmp-${PV}
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="http://openmp.llvm.org"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.8"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}.src"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.0-os_detection.patch
+ "${FILESDIR}"/${PN}-3.7.0-no_compat_symlinks.patch
+ )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++11; then
+ eerror "${P} requires C++11-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++11 option. Please upgrade your compiler"
+ eerror "to gcc-4.7 or an equivalent version supporting C++11."
+ die "Currently active compiler does not support -std=c++11"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=( "-DLIBOMP_LIBDIR_SUFFIX=${libdir#lib}" )
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+}