summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-07-21 10:20:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-21 10:32:22 +0200
commit9c5a52ace71fe4c98e3b15a287d0d316f5d37908 (patch)
treedef9f1f8fbf5454e129a277a07706c084dfda25d /sys-libs/libseccomp
parentdev-python/cheroot: keyworded 8.3.1 for ia64 (diff)
downloadgentoo-9c5a52ace71fe4c98e3b15a287d0d316f5d37908.tar.gz
gentoo-9c5a52ace71fe4c98e3b15a287d0d316f5d37908.tar.bz2
gentoo-9c5a52ace71fe4c98e3b15a287d0d316f5d37908.zip
sys-libs/libseccomp: New live ebuild
Bug: https://bugs.gentoo.org/732382 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/libseccomp-9999.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/libseccomp-9999.ebuild b/sys-libs/libseccomp/libseccomp-9999.ebuild
new file mode 100644
index 000000000000..5604393c136c
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/seccomp/libseccomp.git"
+ PRERELEASE="2.5.0"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="python static-libs"
+
+REQUIRED_USE="python? ( static-libs )"
+
+BDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${BDEPEND}"
+RDEPEND="${DEPEND}"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND="${DEPEND} >=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ default
+ if [[ "${PV}" == *9999 ]] ; then
+ sed -i -e "s/0.0.0/${PRERELEASE}/" configure.ac
+ eautoreconf
+ fi
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-python
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use python ; then
+ cd "${S}/src/python" || die
+ sed -i -e "s/=.*VERSION_RELEASE.*,/=\"${PRERELEASE}\",/" -e "/extra_objects/s,\.\.,${OLDPWD}/src," setup.py
+ local -x CPPFLAGS="-I${OLDPWD}/include -I../../include"
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python ; then
+ cd "${S}/src/python" || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "${PN}.la" -delete || die
+ einstalldocs
+}