summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-08-17 16:57:10 +0800
committerJason Zaman <perfinion@gentoo.org>2019-08-17 16:59:30 +0800
commit0a7081d5936452e693ba741acfd3429d43b1534f (patch)
tree7759380d94a1fa30ab0bd13a1d3c7015a048bcd5 /sys-libs/libsepol/libsepol-2.7.ebuild
parentsys-libs/libsepol: stable (diff)
downloadgentoo-0a7081d5936452e693ba741acfd3429d43b1534f.tar.gz
gentoo-0a7081d5936452e693ba741acfd3429d43b1534f.tar.bz2
gentoo-0a7081d5936452e693ba741acfd3429d43b1534f.zip
sys-libs/libsepol: drop old
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-libs/libsepol/libsepol-2.7.ebuild')
-rw-r--r--sys-libs/libsepol/libsepol-2.7.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sys-libs/libsepol/libsepol-2.7.ebuild b/sys-libs/libsepol/libsepol-2.7.ebuild
deleted file mode 100644
index 9b566349dc01..000000000000
--- a/sys-libs/libsepol/libsepol-2.7.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit multilib toolchain-funcs multilib-minimal
-
-MY_P="${P//_/-}"
-MY_RELEASEDATE="20170804"
-
-DESCRIPTION="SELinux binary policy representation library"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
-else
- SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-# tests are not meant to be run outside of the full SELinux userland repo
-RESTRICT="test"
-
-src_prepare() {
- eapply_user
- multilib_copy_sources
-}
-
-multilib_src_compile() {
- tc-export RANLIB;
- LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
- emake AR="$(tc-getAR)" CC="$(tc-getCC)"
-}
-
-multilib_src_install() {
- LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
- emake DESTDIR="${D}" install
-}