summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:18 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:18 +0100
commitc89a2d379bddbaf84c39152431dd1876133ae8f8 (patch)
treeae364f55fec1baed17a88a5fcb2872069f5eac77 /sys-libs/suacomp
parentsys-block/megamgr: Port to EAPI 6 (diff)
downloadgentoo-c89a2d379bddbaf84c39152431dd1876133ae8f8.tar.gz
gentoo-c89a2d379bddbaf84c39152431dd1876133ae8f8.tar.bz2
gentoo-c89a2d379bddbaf84c39152431dd1876133ae8f8.zip
sys-libs/suacomp: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/suacomp')
-rw-r--r--sys-libs/suacomp/suacomp-0.6.14.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/sys-libs/suacomp/suacomp-0.6.14.ebuild b/sys-libs/suacomp/suacomp-0.6.14.ebuild
index be3cecaf4bfc..be3e9886e4e5 100644
--- a/sys-libs/suacomp/suacomp-0.6.14.ebuild
+++ b/sys-libs/suacomp/suacomp-0.6.14.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
-inherit toolchain-funcs flag-o-matic eutils
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
HOMEPAGE="http://suacomp.sf.net"
@@ -21,9 +21,11 @@ get_opts() {
local shlibc=
local stlibc=
+ local dir
for dir in /usr/lib /usr/lib/x86; do
[[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+ local name
for name in libc.so.5.2 libc.so.3.5; do
[[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
done
@@ -34,23 +36,19 @@ get_opts() {
echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
}
-pkg_setup() {
+src_prepare() {
+ [[ ${CHOST} == *-interix6* ]] && eapply "${FILESDIR}"/${P}-strtoll.patch
+ eapply_user
+}
+
+src_configure() {
if use debug; then
append-flags -D_DEBUG -D_DEBUG_TRACE
fi
}
-src_prepare() {
- [[ ${CHOST} == *-interix6* ]] && epatch "${FILESDIR}"/${P}-strtoll.patch
-}
-
src_compile() {
- emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
- CFLAGS="${CFLAGS}" || die "emake install failed"
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}"
}
src_test() {
@@ -59,5 +57,10 @@ src_test() {
use debug && v="TEST_VERBOSE=1"
use debug && export SUACOMP_DEBUG_OUT=stderr
- emake check $(get_opts) ${v} || die "emake check failed"
+ emake check $(get_opts) ${v}
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}"
}