summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-23 11:09:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-23 12:02:10 +0100
commit00366539c1495c59912b3d23a8b7548576bb93d2 (patch)
tree178ec7f5edfd42090298a724cacf0561665b2bdc /sys-libs/tdb
parentsys-libs/nss_wrapper: Bump to version 1.1.0 (diff)
downloadgentoo-00366539c1495c59912b3d23a8b7548576bb93d2.tar.gz
gentoo-00366539c1495c59912b3d23a8b7548576bb93d2.tar.bz2
gentoo-00366539c1495c59912b3d23a8b7548576bb93d2.zip
sys-libs/tdb: Bump to version 1.3.8
Package-Manager: portage-2.2.25 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/Manifest1
-rw-r--r--sys-libs/tdb/tdb-1.3.8.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index 069eee5b530f..5b1401d4c254 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,3 +1,4 @@
DIST tdb-1.3.0.tar.gz 479096 SHA256 04bee48d405ab7815810575a6e0cb364cc0eea6187b54b18c84e9c18a768ba20 SHA512 b9a66070002879119627bae82d8bafeb52ae336afdc4d97e14a7e4ff78e42c7c516f8349781964c2bfbbcc6949247c5fa9519f936c884151ffff9e121f9f9334 WHIRLPOOL 88da0b12ecdc8746bf627f2e1ce896b1a2b435c1dc34cd5649cd1554aa2cf90fe16014dd31fc45605d6a3dcdf02c3a09b1a43e68527497379734a96a3dd99711
DIST tdb-1.3.6.tar.gz 490881 SHA256 85d7dd247e58d8b303de542a2bc39a3dff9e5f54dea39a94c1c910cee25a59a5 SHA512 be372865e3b809897d46b3ac134de3569185366a0b608e09836e6e37657ae7d0afdcb6b1d4990fee54d16a004e7e792987f51a974fc44fa4632c695e8b1e9341 WHIRLPOOL f278ab51e2716b0948cb8c802d3380d8ca08a31d414d71168d7e786f0113f8a78fbda39977b8b0f8d0007a50df98f4e19d4c2a4f24b192cf20e67c1c4efa491a
DIST tdb-1.3.7.tar.gz 493847 SHA256 a64d95ca0cc06a28fed24c6e952aed7660cae04983108735d6bc30b925136412 SHA512 661404df8328a2e7bbb0d7865759e299edafee186f3798c11034c36b2076402a826306007986d6cdd5bf8774d2af7ebf4312a501ca9d9e62a26e504bc13652e4 WHIRLPOOL 92586febe155e87ffadd7cdfd3e83b75d51d41cb3e3e70b886a371f01b1e7c628a02217afff9eb33dadab23849afec18e5c4f78f30def549e629adafa1437479
+DIST tdb-1.3.8.tar.gz 494106 SHA256 0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1 SHA512 9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b WHIRLPOOL 61070a71aba9b44d5141844ffac6b4657ddc938850934fe00ff7312d9f76e1c318e37764b60fbac255ff5b8dc8d8226f668f80315fccdc67550eeb9bd1c4bc25
diff --git a/sys-libs/tdb/tdb-1.3.8.ebuild b/sys-libs/tdb/tdb-1.3.8.ebuild
new file mode 100644
index 000000000000..884d02974449
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils multilib-minimal python-single-r1 eutils
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}