summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-29 09:22:50 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-29 09:23:15 -0400
commit003eb41c3b2333941eaeee79c11b4a37d32ad9c6 (patch)
treec8b77b8f33eb29664ba2433bb68ffe764ff0a17a /sys-libs/zlib/zlib-1.2.7.ebuild
parentapp-emulation/qemu: update smartcard configure flag #561670 (diff)
downloadgentoo-003eb41c3b2333941eaeee79c11b4a37d32ad9c6.tar.gz
gentoo-003eb41c3b2333941eaeee79c11b4a37d32ad9c6.tar.bz2
gentoo-003eb41c3b2333941eaeee79c11b4a37d32ad9c6.zip
sys-libs/zlib: drop old
Diffstat (limited to 'sys-libs/zlib/zlib-1.2.7.ebuild')
-rw-r--r--sys-libs/zlib/zlib-1.2.7.ebuild99
1 files changed, 0 insertions, 99 deletions
diff --git a/sys-libs/zlib/zlib-1.2.7.ebuild b/sys-libs/zlib/zlib-1.2.7.ebuild
deleted file mode 100644
index 3155b6bb2f54..000000000000
--- a/sys-libs/zlib/zlib-1.2.7.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-AUTOTOOLS_AUTO_DEPEND="no"
-inherit autotools toolchain-funcs multilib
-
-DESCRIPTION="Standard (de)compression library"
-HOMEPAGE="http://www.zlib.net/"
-SRC_URI="http://zlib.net/${P}.tar.gz
- http://www.gzip.org/zlib/${P}.tar.gz
- http://www.zlib.net/current/beta/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="minizip static-libs"
-
-DEPEND="minizip? ( ${AUTOTOOLS_DEPEND} )"
-RDEPEND="!<dev-libs/libxml2-2.7.7" #309623
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use minizip ; then
- cd contrib/minizip
- eautoreconf
- fi
-}
-
-echoit() { echo "$@"; "$@"; }
-src_compile() {
- case ${CHOST} in
- *-mingw*|mingw*)
- emake -f win32/Makefile.gcc STRIP=true PREFIX=${CHOST}- || die
- sed \
- -e 's|@prefix@|/usr|g' \
- -e 's|@exec_prefix@|${prefix}|g' \
- -e 's|@libdir@|${exec_prefix}/'$(get_libdir)'|g' \
- -e 's|@sharedlibdir@|${exec_prefix}/'$(get_libdir)'|g' \
- -e 's|@includedir@|${prefix}/include|g' \
- -e 's|@VERSION@|'${PV}'|g' \
- zlib.pc.in > zlib.pc || die
- ;;
- *) # not an autoconf script, so can't use econf
- local uname=$(/usr/share/gnuconfig/config.sub "${CHOST}" | cut -d- -f3) #347167
- echoit ./configure \
- --shared \
- --prefix=/usr \
- --libdir=/usr/$(get_libdir) \
- ${uname:+--uname=${uname}} \
- || die
- emake || die
- ;;
- esac
- if use minizip ; then
- cd contrib/minizip
- econf $(use_enable static-libs static)
- emake || die
- fi
-}
-
-sed_macros() {
- # clean up namespace a little #383179
- # we do it here so we only have to tweak 2 files
- sed -i -r 's:\<(O[FN])\>:_Z_\1:g' "$@" || die
-}
-src_install() {
- case ${CHOST} in
- *-mingw*|mingw*)
- emake -f win32/Makefile.gcc install \
- BINARY_PATH="${D}/usr/bin" \
- LIBRARY_PATH="${D}/usr/$(get_libdir)" \
- INCLUDE_PATH="${D}/usr/include" \
- SHARED_MODE=1 \
- || die
- insinto /usr/share/pkgconfig
- doins zlib.pc || die
- ;;
-
- *)
- emake install DESTDIR="${D}" LDCONFIG=: || die
- gen_usr_ldscript -a z
- ;;
- esac
- sed_macros "${D}"/usr/include/*.h
-
- dodoc FAQ README ChangeLog doc/*.txt
-
- if use minizip ; then
- cd contrib/minizip
- emake install DESTDIR="${D}" || die
- sed_macros "${D}"/usr/include/minizip/*.h
- dodoc *.txt
- fi
-
- use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib{z,minizip}.{a,la} #419645
-}