summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:49 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:51 +0100
commit0392383fc9f0c13a5854bf69a9b7f061c13d58f7 (patch)
tree5c3f792e5ca26cca0d1e0019b996d1fdeca1e3bb /sys-libs
parentsys-devel/llvm: Switch live to monorepo (diff)
downloadgentoo-0392383fc9f0c13a5854bf69a9b7f061c13d58f7.tar.gz
gentoo-0392383fc9f0c13a5854bf69a9b7f061c13d58f7.tar.bz2
gentoo-0392383fc9f0c13a5854bf69a9b7f061c13d58f7.zip
sys-libs/compiler-rt-sanitizers: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-10.0.0.9999.ebuild22
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9.0.1.9999.ebuild24
2 files changed, 15 insertions, 31 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-10.0.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-10.0.0.9999.ebuild
index a2a2f1e49bf9..0ef9de1da9b2 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-10.0.0.9999.ebuild
@@ -14,8 +14,8 @@ inherit check-reqs cmake-utils flag-o-matic git-r3 llvm \
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
- https://github.com/llvm-mirror/compiler-rt.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/compiler-rt
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -60,18 +60,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( compiler-rt )
+ use test && dirs+=( llvm/lib/Testing/Support llvm/utils/unittest )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/unittest
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_prepare() {
@@ -88,7 +80,7 @@ src_prepare() {
src_configure() {
# pre-set since we need to pass it to cmake
- BUILD_DIR=${WORKDIR}/${P}_build
+ BUILD_DIR=${WORKDIR}/${P}/compiler-rt_build
if use clang; then
local -x CC=${CHOST}-clang
@@ -113,7 +105,7 @@ src_configure() {
)
if use test; then
mycmakeargs+=(
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9.0.1.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9.0.1.9999.ebuild
index f147105624d8..ffb67b0bddf6 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9.0.1.9999.ebuild
@@ -14,9 +14,9 @@ inherit check-reqs cmake-utils flag-o-matic git-r3 llvm \
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
- https://github.com/llvm-mirror/compiler-rt.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/compiler-rt
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -61,18 +61,10 @@ pkg_setup() {
}
src_unpack() {
- if use test; then
- # needed for patched gtest
- git-r3_fetch "https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
- fi
+ local dirs=( compiler-rt )
+ use test && dirs+=( llvm/utils/unittest )
git-r3_fetch
-
- if use test; then
- git-r3_checkout https://llvm.org/git/llvm.git \
- "${WORKDIR}"/llvm '' utils/unittest
- fi
- git-r3_checkout
+ git-r3_checkout '' '' '' "${dirs[@]}"
}
src_prepare() {
@@ -89,7 +81,7 @@ src_prepare() {
src_configure() {
# pre-set since we need to pass it to cmake
- BUILD_DIR=${WORKDIR}/${P}_build
+ BUILD_DIR=${WORKDIR}/${P}/compiler-rt_build
if use clang; then
local -x CC=${CHOST}-clang
@@ -114,7 +106,7 @@ src_configure() {
)
if use test; then
mycmakeargs+=(
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"