summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-16 10:08:44 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-16 10:32:35 +0100
commit367e23c07ea0a6102eb674f02b649885275dd8e8 (patch)
treeb9575d626633c7a86734cba540cb2f2bf226809b /sys-libs
parentsys-libs/libcxxabi: Fix missing -L path for tests (diff)
downloadgentoo-367e23c07ea0a6102eb674f02b649885275dd8e8.tar.gz
gentoo-367e23c07ea0a6102eb674f02b649885275dd8e8.tar.bz2
gentoo-367e23c07ea0a6102eb674f02b649885275dd8e8.zip
sys-libs/llvm-libunwind: Fix running multilib tests
Fix tests to use multilib-wrapped compiler. Otherwise, the tests were actually done using native ABI library which missed the point. Also, add missing MULTILIB_USEDEP.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild9
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild9
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild9
3 files changed, 21 insertions, 6 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
index fcc113a63c9c..fe3c0e9d6420 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.0.ebuild
@@ -29,9 +29,9 @@ RDEPEND="!sys-libs/libunwind"
# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
- test? (
+ test? ( >=sys-devel/clang-3.9.0
sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
- sys-libs/libcxxabi
+ sys-libs/libcxxabi[${MULTILIB_USEDEP}]
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
S=${WORKDIR}/${MY_P}
@@ -84,6 +84,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+ sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
+
cmake-utils_src_make check-unwind
}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 6eb95d733fc2..83db4453f60b 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -28,9 +28,9 @@ RDEPEND="!sys-libs/libunwind"
# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
- test? (
+ test? ( >=sys-devel/clang-3.9.0
sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
- sys-libs/libcxxabi
+ sys-libs/libcxxabi[${MULTILIB_USEDEP}]
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
# least intrusive of all
@@ -84,6 +84,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+ sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
+
cmake-utils_src_make check-unwind
}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index 387b8c31086c..238afe790e63 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -27,9 +27,9 @@ RDEPEND="!sys-libs/libunwind"
# (but libcxx does not need to be built against it)
DEPEND="
>=sys-devel/llvm-6
- test? (
+ test? ( >=sys-devel/clang-3.9.0
sys-libs/libcxx[libunwind,${MULTILIB_USEDEP}]
- sys-libs/libcxxabi
+ sys-libs/libcxxabi[${MULTILIB_USEDEP}]
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
# least intrusive of all
@@ -83,6 +83,11 @@ multilib_src_configure() {
}
multilib_src_test() {
+ local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
+
+ [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
+ sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
+
cmake-utils_src_make check-unwind
}