summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-09-06 00:39:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-06 00:39:59 +0200
commit6ae4a51986ef113810101e7bb79ae38bb0ed427c (patch)
treef9fed774a057af2539ea0291e7642e2c17fb3223 /sys-libs
parentprofiles: remove mask on =sys-fs/eudev-3.2.3, punted from tree (diff)
downloadgentoo-6ae4a51986ef113810101e7bb79ae38bb0ed427c.tar.gz
gentoo-6ae4a51986ef113810101e7bb79ae38bb0ed427c.tar.bz2
gentoo-6ae4a51986ef113810101e7bb79ae38bb0ed427c.zip
sys-libs/libblockdev: python is non-optional (bug #629768).
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libblockdev/libblockdev-2.11.ebuild10
-rw-r--r--sys-libs/libblockdev/libblockdev-2.12.ebuild10
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-libs/libblockdev/libblockdev-2.11.ebuild b/sys-libs/libblockdev/libblockdev-2.11.ebuild
index 11dae613f101..6a7e87b7e89c 100644
--- a/sys-libs/libblockdev/libblockdev-2.11.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.11.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/rhinstaller/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="bcache crypt dmraid doc lvm kbd python test"
+IUSE="bcache crypt dmraid doc lvm kbd test"
CDEPEND="
>=dev-libs/glib-2.42.2
@@ -36,7 +36,7 @@ CDEPEND="
virtual/udev
)
kbd? ( >=sys-apps/kmod-19 )
- python? ( ${PYTHON_DEPS} )
+ ${PYTHON_DEPS}
"
DEPEND="
@@ -49,12 +49,12 @@ RDEPEND="
${CDEPEND}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {
@@ -67,6 +67,7 @@ src_configure() {
--with-btrfs
--with-fs
--with-part
+ --with-python3
--without-mpath
$(use_enable test tests)
$(use_with bcache)
@@ -76,7 +77,6 @@ src_configure() {
$(use_with lvm lvm)
$(use_with lvm lvm-dbus)
$(use_with kbd)
- $(use_with python python3)
)
econf "${myeconfargs[@]}"
}
diff --git a/sys-libs/libblockdev/libblockdev-2.12.ebuild b/sys-libs/libblockdev/libblockdev-2.12.ebuild
index 1da1e81fbb71..53c3efbcb20a 100644
--- a/sys-libs/libblockdev/libblockdev-2.12.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.12.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/rhinstaller/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="bcache +crypt dmraid doc lvm kbd python test"
+IUSE="bcache +crypt dmraid doc lvm kbd test"
CDEPEND="
>=dev-libs/glib-2.42.2
@@ -36,7 +36,7 @@ CDEPEND="
virtual/udev
)
kbd? ( >=sys-apps/kmod-19 )
- python? ( ${PYTHON_DEPS} )
+ ${PYTHON_DEPS}
"
DEPEND="
@@ -49,12 +49,12 @@ RDEPEND="
${CDEPEND}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {
@@ -67,6 +67,7 @@ src_configure() {
--with-btrfs
--with-fs
--with-part
+ --with-python3
--without-mpath
$(use_enable test tests)
$(use_with bcache)
@@ -76,7 +77,6 @@ src_configure() {
$(use_with lvm lvm)
$(use_with lvm lvm-dbus)
$(use_with kbd)
- $(use_with python python3)
)
econf "${myeconfargs[@]}"
}