summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-04 23:02:56 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-04 23:10:12 +0200
commitb235a2470ee34d41f4aa93bd7960a1d6297c7c68 (patch)
treecba06d89cb6e34ec210f5097ad2fb4d506be6069 /sys-libs
parentmedia-libs/aubio: stable 0.4.7 for sparc, bug #667510 (diff)
downloadgentoo-b235a2470ee34d41f4aa93bd7960a1d6297c7c68.tar.gz
gentoo-b235a2470ee34d41f4aa93bd7960a1d6297c7c68.tar.bz2
gentoo-b235a2470ee34d41f4aa93bd7960a1d6297c7c68.zip
sys-libs/libcxx: Fix finding libsupc++ ABI headers for multilib
Fix the logic determining path to libsupc++ ABI headers to avoid being affected by CHOST alterations done as part of multilib logic. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-3.9.1.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-4.0.1.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-5.0.2.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-6.0.1.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-7.0.0.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-7.0.9999.ebuild8
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild8
7 files changed, 49 insertions, 7 deletions
diff --git a/sys-libs/libcxx/libcxx-3.9.1.ebuild b/sys-libs/libcxx/libcxx-3.9.1.ebuild
index e847a9f5d318..d5282680825b 100644
--- a/sys-libs/libcxx/libcxx-3.9.1.ebuild
+++ b/sys-libs/libcxx/libcxx-3.9.1.ebuild
@@ -86,7 +86,9 @@ src_configure() {
cmake-multilib_src_configure
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -100,6 +102,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON
diff --git a/sys-libs/libcxx/libcxx-4.0.1.ebuild b/sys-libs/libcxx/libcxx-4.0.1.ebuild
index 64f610ce5bb2..4273ce8d76ec 100644
--- a/sys-libs/libcxx/libcxx-4.0.1.ebuild
+++ b/sys-libs/libcxx/libcxx-4.0.1.ebuild
@@ -71,7 +71,9 @@ pkg_setup() {
fi
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -85,6 +87,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON
diff --git a/sys-libs/libcxx/libcxx-5.0.2.ebuild b/sys-libs/libcxx/libcxx-5.0.2.ebuild
index bd65e51b774b..eda78625c067 100644
--- a/sys-libs/libcxx/libcxx-5.0.2.ebuild
+++ b/sys-libs/libcxx/libcxx-5.0.2.ebuild
@@ -71,7 +71,9 @@ pkg_setup() {
fi
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -85,6 +87,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON
diff --git a/sys-libs/libcxx/libcxx-6.0.1.ebuild b/sys-libs/libcxx/libcxx-6.0.1.ebuild
index 6c5c866f9c61..5d8314c5988a 100644
--- a/sys-libs/libcxx/libcxx-6.0.1.ebuild
+++ b/sys-libs/libcxx/libcxx-6.0.1.ebuild
@@ -78,7 +78,9 @@ test_compiler() {
<<<'int main() { return 0; }' &>/dev/null
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -92,6 +94,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON
diff --git a/sys-libs/libcxx/libcxx-7.0.0.ebuild b/sys-libs/libcxx/libcxx-7.0.0.ebuild
index 3a997e98c088..d94f0c1c617e 100644
--- a/sys-libs/libcxx/libcxx-7.0.0.ebuild
+++ b/sys-libs/libcxx/libcxx-7.0.0.ebuild
@@ -78,7 +78,9 @@ test_compiler() {
<<<'int main() { return 0; }' &>/dev/null
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -92,6 +94,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON
diff --git a/sys-libs/libcxx/libcxx-7.0.9999.ebuild b/sys-libs/libcxx/libcxx-7.0.9999.ebuild
index e5777074eeda..536457a13802 100644
--- a/sys-libs/libcxx/libcxx-7.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-7.0.9999.ebuild
@@ -90,7 +90,9 @@ test_compiler() {
<<<'int main() { return 0; }' &>/dev/null
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -104,6 +106,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 4272b2117944..2547da3dfa77 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -89,7 +89,9 @@ test_compiler() {
<<<'int main() { return 0; }' &>/dev/null
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -103,6 +105,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON