summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-15 12:45:15 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-15 12:45:56 +0100
commitb406f50c74400237d176cf74f7bc8052963ad999 (patch)
treef36d6ecb314eda8c4dd92603026d2e6cffa83c2f /sys-libs
parentwww-client/opera: Stable for AMD64 too (diff)
downloadgentoo-b406f50c74400237d176cf74f7bc8052963ad999.tar.gz
gentoo-b406f50c74400237d176cf74f7bc8052963ad999.tar.bz2
gentoo-b406f50c74400237d176cf74f7bc8052963ad999.zip
sys-libs/libseccomp: Security bump to version 2.4.0
Bug: https://bugs.gentoo.org/680442 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libseccomp/Manifest1
-rw-r--r--sys-libs/libseccomp/libseccomp-2.4.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/Manifest b/sys-libs/libseccomp/Manifest
index 951e4c47b4be..6e7f3313701e 100644
--- a/sys-libs/libseccomp/Manifest
+++ b/sys-libs/libseccomp/Manifest
@@ -1,2 +1,3 @@
DIST libseccomp-2.3.2.tar.gz 559238 BLAKE2B 0040ad977431ae9731dadcae11b0099d3ec788462f89cdf80c77b71405ce02c122c3859836aaa9469ec7112b0bf32cc87c9b102bb3e8b2e669ded54677db64d1 SHA512 0864a53ba2be61d0207f7361af94bcda4acff84a1814f915e6ccb19ab24f6ccc978da0eedc5cee047fa655dc1a583e2eeb7ab985ebfc77491c6a2606727b79ec
DIST libseccomp-2.3.3.tar.gz 564546 BLAKE2B b5249379baf07ab2fef8a8659a30c9e87cbf05f99c38a07c1516948d2ede27d505f6670426f46422d2a927d7bfe97a33d8f871899ae9c30a26fbd10fba609df8 SHA512 845c7e0e916b5f5ad74da446ceff3250148b745c909185f6d5059e807d1b42fa6b74f356cce2a396bff0d4c7a3120e7cdad98d490a97d549327c7693fe1918be
+DIST libseccomp-2.4.0.tar.gz 604987 BLAKE2B 2dd84f2c08d40a61dfe4fdc47a9dcdad2701e2918cdcdeae2d15a66eb114221866121bab11a8292f3bd31493b6cd7b370d0728976cb1bbfd0dbb9e32127b9045 SHA512 daa4a32c6c2b2f39aa9db1a4606619f9faeffcd2fca00c25ac5cf95d0405639ec21203293be7c8341317a05b18fd9f603a201544457cac91bf034a0bbd4dfc88
diff --git a/sys-libs/libseccomp/libseccomp-2.4.0.ebuild b/sys-libs/libseccomp/libseccomp-2.4.0.ebuild
new file mode 100644
index 000000000000..96b995d7b0db
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/_LDFLAGS/s:-static::' \
+ tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-python
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name libseccomp.la -delete
+ einstalldocs
+}