summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:56:45 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:33 +0100
commitbe23ef27bb0052d569e07b2df063f2db6fa5719e (patch)
treeec0c708fa68f841eaa58c6dbf15b356bc2077681 /sys-libs
parentsys-libs/libcxx: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo (diff)
downloadgentoo-be23ef27bb0052d569e07b2df063f2db6fa5719e.tar.gz
gentoo-be23ef27bb0052d569e07b2df063f2db6fa5719e.tar.bz2
gentoo-be23ef27bb0052d569e07b2df063f2db6fa5719e.zip
sys-libs/libomp: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libomp/libomp-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/libomp/libomp-9999.ebuild b/sys-libs/libomp/libomp-9999.ebuild
index a61c877c62d5..39bed8fc832e 100644
--- a/sys-libs/libomp/libomp-9999.ebuild
+++ b/sys-libs/libomp/libomp-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit cmake-multilib git-r3 python-any-r1
@@ -37,6 +39,9 @@ DEPEND="${RDEPEND}
>=sys-devel/clang-3.9.0
)"
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}