summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2018-09-10 14:18:58 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2018-09-10 14:42:09 -0700
commite4b90363a83dc31ca7e5afdf425b25328e9c89a5 (patch)
treef3087401a91506c7790e82f6d8061799f50db1d6 /sys-libs
parentmedia-gfx/gimp: Add gdbus-codegen to DEPEND of 9999 (diff)
downloadgentoo-e4b90363a83dc31ca7e5afdf425b25328e9c89a5.tar.gz
gentoo-e4b90363a83dc31ca7e5afdf425b25328e9c89a5.tar.bz2
gentoo-e4b90363a83dc31ca7e5afdf425b25328e9c89a5.zip
sys-libs/efivar: bump per fwupd testing
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/efivar/Manifest1
-rw-r--r--sys-libs/efivar/efivar-36.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/efivar/Manifest b/sys-libs/efivar/Manifest
index 5f36bb009703..fe4dfe339214 100644
--- a/sys-libs/efivar/Manifest
+++ b/sys-libs/efivar/Manifest
@@ -2,3 +2,4 @@ DIST efivar-30.tar.bz2 73202 BLAKE2B 6b146cb6d664e3419361e72ab6fd1578522e7fc2196
DIST efivar-31.tar.bz2 82404 BLAKE2B d339aa8ab7dcd6a60cb067fccfbc2c42407fba211ca96eb39f227d57e9403462505940f427651dfaffa8272c9edfe70898f181b9f6ecddbae4745eb3262de949 SHA512 5055f690fd99cf59895dcf3d11103494d917d4923567626f0bee816ea5e4dd56cec23627ede5f21bdc57b7306522471ad19cc8ab22ae94591dbd1925c084f163
DIST efivar-32.tar.gz 108102 BLAKE2B 7f9d27433b40ec6c044ab34ccc697001ad23e39a46862d2e04db0f9a3dfc26ae53b46a3c3a8c957bf76df0969710f78249f72f7bf38e67c0aa902034a07acf8f SHA512 e73eae182fd645183dfe587591a286670ee1123a113e3e19e4070fb910ab7794e320defdc0597540df7664947f2a0497abbb763a19b4dfa40511a512c7f3e490
DIST efivar-35.tar.bz2 95528 BLAKE2B c936114aade7a586f707af2464d350703234e0c3fb786fb568590737fb3939c3f74ff813f4f188aec230d75e75e73b0d07cbff5860f0b9f1285d2780b29c7689 SHA512 c7ba60b2112053f088ad0b74aaa834860601b7fe17118c35b012050176f5205d948fba9c4b6de35991249f702e3bc24832539e2eb3c235c4188e1eabc78965ee
+DIST efivar-36.tar.bz2 105928 BLAKE2B bcaff4e81d7591e3655d3e2b150c6f7006335b6dd1981bcd7b5a658e93adee4f7fa6d0dd6ce5b9854b5b409e2a4b7db692d4d670670dc34660035c840a18682d SHA512 951feabe2d238826fdd6e74e8f7a24f04d705f9ef925cfcfb852944d2d7a4f04e3a6c23f276c40e5564da42614558941dbe7aaf21efa6a722a616e4d165aba2d
diff --git a/sys-libs/efivar/efivar-36.ebuild b/sys-libs/efivar/efivar-36.ebuild
new file mode 100644
index 000000000000..93339047a52a
--- /dev/null
+++ b/sys-libs/efivar/efivar-36.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools and library to manipulate EFI variables"
+HOMEPAGE="https://github.com/rhinstaller/efivar"
+SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i -e 's/-Werror //' gcc.specs || die
+}
+
+src_configure() {
+ tc-export CC
+ export CC_FOR_BUILD=$(tc-getBUILD_CC)
+ tc-ld-disable-gold
+ export libdir="/usr/$(get_libdir)"
+ unset LIBS # Bug 562004
+
+ if [[ -n ${GCC_SPECS} ]]; then
+ # The environment overrides the command line.
+ GCC_SPECS+=":${S}/gcc.specs"
+ fi
+}