summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-11-15 15:06:23 -0500
committerBrian Evans <grknight@gentoo.org>2016-11-15 15:06:23 -0500
commit4175b849a4e262047f8e148dfc4f48c009fb55e3 (patch)
treee948076925ce3a21860dd709372e5aae9f29af8e /sys-power/acpilight
parentdev-python/keyring: revbump adding missing dep for bug 599906 (diff)
downloadgentoo-4175b849a4e262047f8e148dfc4f48c009fb55e3.tar.gz
gentoo-4175b849a4e262047f8e148dfc4f48c009fb55e3.tar.bz2
gentoo-4175b849a4e262047f8e148dfc4f48c009fb55e3.zip
sys-power/acpilight: Add new snapshot version
Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-power/acpilight')
-rw-r--r--sys-power/acpilight/Manifest1
-rw-r--r--sys-power/acpilight/acpilight-0_pre20161031.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-power/acpilight/Manifest b/sys-power/acpilight/Manifest
index ba2fb478e83e..6901174e4a44 100644
--- a/sys-power/acpilight/Manifest
+++ b/sys-power/acpilight/Manifest
@@ -1 +1,2 @@
DIST acpilight-0_pre20160724.tar.gz 2125 SHA256 d57f71561fd73289c3b81332c08619ac3edcc295bcfe7fd1840e512d00e0835b SHA512 a249f46afcb2f45c6f85769e4c6de1751da4cb432012db51b8682a7dc1454fe2cffbe5694ea18bdc275b4c302f911b68f104d3e7b4c8e9b8ac114cbecc91fc56 WHIRLPOOL 57a2f01a74046662102fe35715b161ef94ffb83db038547424d99f95cee3b432b2151fd7c7b7cde3b1dd19cfa339548c8c3b795c440dba24e48a31760b645c0a
+DIST acpilight-0_pre20161031.tar.gz 2218 SHA256 d8050cc73d917d0719b68066febc3f301003cbb00c4b2e8519a27ba6335ce4d6 SHA512 08f2c9d3ba14f4a756aa635c16f8928a06dc196c1507120c40f3ef8ba681bc75b37bf1c4cd04bbb2ca033b8948ca1353324dddb8118a12e5fda17d717dc7d1e1 WHIRLPOOL 43a426a4ec39d2efd6e040e07be295f6a1230fe1ac2133bcebe368b6c9afc4657c234529f2dd139e41d467ef8e67d1ed381316eb124ebf1989d8fccc1cc5dbd5
diff --git a/sys-power/acpilight/acpilight-0_pre20161031.ebuild b/sys-power/acpilight/acpilight-0_pre20161031.ebuild
new file mode 100644
index 000000000000..3f45af61261a
--- /dev/null
+++ b/sys-power/acpilight/acpilight-0_pre20161031.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit python-r1 udev vcs-snapshot
+
+VCS_COMMIT="7c01b2fc0271603809b67c7d3015f4b7b3d9a96e"
+DESCRIPTION="Replacement for xbacklight that uses the ACPI interface to set brightness"
+HOMEPAGE="https://github.com/wavexx/acpilight/"
+SRC_URI="https://github.com/wavexx/acpilight/archive/${VCS_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev
+ ${PYTHON_DEPS}
+ !x11-apps/xbacklight"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.rst )
+
+src_install() {
+ python_foreach_impl python_doscript xbacklight
+ udev_dorules "${S}"/90-backlight.rules
+ einstalldocs
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo
+ elog "To use the xbacklight binary as a regular user, you must be a part of the video group"
+ einfo
+ elog "If this utility does not find any backlights to manipulate,"
+ elog "verify you have kernel support on the device and display driver enabled."
+ einfo
+}