summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-27 22:52:44 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-27 23:10:30 +0100
commitf9dcbc38e60c20821a619f4b6dde53a80623fd9a (patch)
tree81aee214530b8f2c72fbbdfa60562f929a143595 /sys-power/athcool
parentapp-misc/wipe: Port to EAPI 6 (diff)
downloadgentoo-f9dcbc38e60c20821a619f4b6dde53a80623fd9a.tar.gz
gentoo-f9dcbc38e60c20821a619f4b6dde53a80623fd9a.tar.bz2
gentoo-f9dcbc38e60c20821a619f4b6dde53a80623fd9a.zip
sys-power/athcool: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-power/athcool')
-rw-r--r--sys-power/athcool/athcool-0.3.12.ebuild17
-rw-r--r--sys-power/athcool/files/athcool-0.3.11-build.patch4
2 files changed, 9 insertions, 12 deletions
diff --git a/sys-power/athcool/athcool-0.3.12.ebuild b/sys-power/athcool/athcool-0.3.12.ebuild
index b9ed25616659..bd826f25b0f5 100644
--- a/sys-power/athcool/athcool-0.3.12.ebuild
+++ b/sys-power/athcool/athcool-0.3.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="small utility to toggle Powersaving mode for AMD Athlon/Duron processors"
HOMEPAGE="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html#athcool"
@@ -17,18 +17,15 @@ IUSE=""
DEPEND="sys-apps/pciutils"
RDEPEND=""
-pkg_setup() {
- tc-export CC
-}
+PATCHES=( "${FILESDIR}"/${PN}-0.3.11-build.patch )
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.3.11-build.patch
+src_configure() {
+ tc-export CC
}
src_install() {
- emake install DESTDIR="${D}" || die
+ default
doinitd "${FILESDIR}"/athcool
- dodoc README ChangeLog
}
pkg_postinst() {
diff --git a/sys-power/athcool/files/athcool-0.3.11-build.patch b/sys-power/athcool/files/athcool-0.3.11-build.patch
index 8b8e619dd71f..bcf3a3054142 100644
--- a/sys-power/athcool/files/athcool-0.3.11-build.patch
+++ b/sys-power/athcool/files/athcool-0.3.11-build.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -14,13 +14,13 @@
SRCS = athcool.c scanpci.c
OBJS = $(SRCS:.c=.o)