summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:37:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-26 11:51:09 +0200
commit193633b09b01a26152b200ed71816c59490f97e1 (patch)
treeb417e9424f83a4dffeb476769b239045b0e904f9 /sys-power/upower
parentgames-rpg/manaplus: Removed old. (diff)
downloadgentoo-193633b09b01a26152b200ed71816c59490f97e1.tar.gz
gentoo-193633b09b01a26152b200ed71816c59490f97e1.tar.bz2
gentoo-193633b09b01a26152b200ed71816c59490f97e1.zip
sys-power/upower: Bump to version 0.99.5
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-power/upower')
-rw-r--r--sys-power/upower/Manifest1
-rw-r--r--sys-power/upower/upower-0.99.5.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-power/upower/Manifest b/sys-power/upower/Manifest
index d8825486f55e..5118339f19bd 100644
--- a/sys-power/upower/Manifest
+++ b/sys-power/upower/Manifest
@@ -1 +1,2 @@
DIST upower-0.99.4.tar.xz 426292 SHA256 9ca325a6ccef505529b268ebbbd9becd0ce65a65f6ac7ee31e2e5b17648037b0 SHA512 b3fdee5ccf5f4d0c69e227f543272f6952119132814e27bc8f112716b8d36b5e07741a87bcf02203e80ef910cad9ddffa1adecb338c9a9aaa5e1038b62be07f3 WHIRLPOOL f203682b272e2f9ff7b48a1b4ee359569cbce2314edc599bfc82182e274d95446a8b59228e1dc250db9b823efdd8129cb99022b498f6d7af3b79bbc7ccb42f0f
+DIST upower-0.99.5.tar.xz 432344 SHA256 78605664d027c788f6ab63c50950be6e86c6ba5d030c4cf35a6664337d87f3b2 SHA512 2fb06bea69455f538146576665e36c5b91eb18b119fa77e29d383fcb2a86ea58650b82e258f157d03c40147ecb12ea545997199580f0e24847ac6ea04d46e5ea WHIRLPOOL bba93ec4625f2c9e6284d6b22e4391e68411de08bf35b43286003d739d2bf7f57c0e6ad73e6f25bfd8254b73081dc8ff729fe266eeb69cdc9547e2cf856aa646
diff --git a/sys-power/upower/upower-0.99.5.ebuild b/sys-power/upower/upower-0.99.5.ebuild
new file mode 100644
index 000000000000..a884fe3466cc
--- /dev/null
+++ b/sys-power/upower/upower-0.99.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit ltprune systemd
+
+DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
+HOMEPAGE="https://upower.freedesktop.org/"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # based on SONAME of libupower-glib.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# gtk-doc files are not available as prebuilt in the tarball
+IUSE="doc +introspection ios kernel_FreeBSD kernel_linux selinux"
+
+COMMON_DEPS="
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.34:2
+ sys-apps/dbus:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ kernel_linux? (
+ virtual/libusb:1
+ virtual/libgudev:=
+ virtual/udev
+ ios? (
+ >=app-pda/libimobiledevice-1:=
+ >=app-pda/libplist-1:=
+ )
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ selinux? ( sec-policy/selinux-devicekit )
+"
+DEPEND="${COMMON_DEPS}
+ doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+QA_MULTILIB_PATHS="usr/lib/${PN}/.*"
+
+DOCS=( AUTHORS HACKING NEWS README )
+
+src_prepare() {
+ default
+ sed -i -e '/DISABLE_DEPRECATED/d' configure || die
+}
+
+src_configure() {
+ local backend
+
+ if use kernel_linux ; then
+ backend=linux
+ elif use kernel_FreeBSD ; then
+ backend=freebsd
+ else
+ backend=dummy
+ fi
+
+ local myeconfargs=(
+ --disable-static
+ --disable-tests
+ --enable-man-pages
+ --libexecdir="${EPREFIX%/}"/usr/lib/${PN}
+ --localstatedir="${EPREFIX%/}"/var
+ --with-backend=${backend}
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemdutildir="$(systemd_get_utildir)"
+ $(use_enable doc gtk-doc)
+ $(use_enable introspection)
+ $(use_with ios idevice)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ keepdir /var/lib/upower #383091
+ prune_libtool_files
+}