summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-11-25 17:05:40 -0500
committerMike Gilbert <floppym@gentoo.org>2019-11-25 17:10:05 -0500
commit40c51b50c9fe8296918a44b5a22596872f03ccde (patch)
tree144f815a10fc320cc37a2f524e42e69c6067024a /sys-power
parentapp-metrics/dnsmasq_exporter-0.2.0-r1: fix fowners typo (diff)
downloadgentoo-40c51b50c9fe8296918a44b5a22596872f03ccde.tar.gz
gentoo-40c51b50c9fe8296918a44b5a22596872f03ccde.tar.bz2
gentoo-40c51b50c9fe8296918a44b5a22596872f03ccde.zip
sys-power/cpupower: remove old
Package-Manager: Portage-2.3.79_p3, Repoman-2.3.18_p2 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/cpupower/Manifest2
-rw-r--r--sys-power/cpupower/cpupower-3.18.ebuild71
-rw-r--r--sys-power/cpupower/cpupower-4.9.0-r1.ebuild61
3 files changed, 0 insertions, 134 deletions
diff --git a/sys-power/cpupower/Manifest b/sys-power/cpupower/Manifest
index a00729bfdc93..eca4716f0bc6 100644
--- a/sys-power/cpupower/Manifest
+++ b/sys-power/cpupower/Manifest
@@ -1,3 +1 @@
DIST cpupower-4.13.0.tar.xz 67812 BLAKE2B 3b94b18bb57b0499a96d57ca26a48f528bf993e0f1ed7eb6d2949c879de8796501629bd0978946eae925d86dd3204a1cab0c99f1c3a8b51731dfbdb61451e990 SHA512 5e7095e2741eae920a097864926931afb2656e492b504f203c40c24ddc5aee5014c7689b220225171b5ea10c69b70774fb2a979d05ea56ef1fa063f3097626c7
-DIST cpupower-4.9.0.tar.xz 67620 BLAKE2B 0aad0114af52b939f83d80ba89be49a061f46a7597ae2e2f27ee6134dbcb425beefd613b0c3f0217003b700cf9b81cd7538575938e9a867138a78eb6a0247f3e SHA512 67137bd7166a34f131332a5165384ebca5b97deb1c92e6d557195da4be4fecb0c5902159f748ea454461ad2181a778c32b4e4dfd1f8ce7e6a3ec41f553f23677
-DIST linux-3.18.tar.xz 80934708 BLAKE2B cf796fa1eb24276470b51bd3754f02932e57c6469e45959893b3714457ba33f0081ff04137990f228e1aae6d42a05073478a3ef932df468af7cd02bf8c8836c4 SHA512 2f0b72466e9bc538a675738aa416573d41bbbd7e3e2ffd5b5b127afde609ebc278cec5a3c37e73479607e957c13f1b4ed9782a3795e0dcc2cf8e550228594009
diff --git a/sys-power/cpupower/cpupower-3.18.ebuild b/sys-power/cpupower/cpupower-3.18.ebuild
deleted file mode 100644
index 0dcdb330bbc9..000000000000
--- a/sys-power/cpupower/cpupower-3.18.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="https://www.kernel.org/pub/linux/kernel/v3.x/linux-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE="cpufreq_bench debug nls"
-
-# File collision w/ headers of the deprecated cpufrequtils
-RDEPEND="sys-apps/pciutils
- !<sys-apps/linux-misc-apps-3.6-r2
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/linux-${PV}/tools/power/${PN}
-
-pkg_setup() {
- myemakeargs=(
- DEBUG=$(usex debug true false)
- V=1
- CPUFREQ_BENCH=$(usex cpufreq_bench true false)
- NLS=$(usex nls true false)
- docdir=/usr/share/doc/${PF}/${PN}
- mandir=/usr/share/man
- libdir=/usr/$(get_libdir)
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- STRIP=true
- LDFLAGS="${LDFLAGS}"
- OPTIMIZATION="${CFLAGS}"
- )
-}
-
-src_unpack() {
- tar -xf "${DISTDIR}"/linux-${PV}.tar.xz \
- linux-${PV}/tools/power/${PN} \
- linux-${PV}/Makefile \
- || die
-}
-
-src_prepare() {
- # -Wl,--as-needed compat
- local libs="-lcpupower -lrt $($(tc-getPKG_CONFIG) --libs-only-l libpci)"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- -e "s:-O1 -g::" \
- Makefile || die
-}
-
-src_compile() {
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 ${PN}
- newinitd "${FILESDIR}"/init.d-r4 ${PN}
-}
diff --git a/sys-power/cpupower/cpupower-4.9.0-r1.ebuild b/sys-power/cpupower/cpupower-4.9.0-r1.ebuild
deleted file mode 100644
index 308a7d815fea..000000000000
--- a/sys-power/cpupower/cpupower-4.9.0-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# eutils: strip-linguas
-inherit eutils systemd toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
-IUSE="cpufreq_bench debug nls"
-
-# File collision w/ headers of the deprecated cpufrequtils
-RDEPEND="sys-apps/pciutils
- !<sys-apps/linux-misc-apps-3.6-r2
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- nls? ( sys-devel/gettext )"
-
-src_compile() {
- myemakeargs=(
- DEBUG=$(usex debug true false)
- V=1
- CPUFREQ_BENCH=$(usex cpufreq_bench true false)
- NLS=$(usex nls true false)
- docdir=/usr/share/doc/${PF}/${PN}
- mandir=/usr/share/man
- libdir=/usr/$(get_libdir)
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- STRIP=true
- OPTIMIZATION=
- VERSION=${PV}
- )
-
- if [[ -n ${LINGUAS+set} ]]; then
- strip-linguas -i po
- myemakeargs+=( LANGUAGES="${LINGUAS}" )
- fi
-
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- doheader lib/cpupower.h
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 cpupower
- newinitd "${FILESDIR}"/init.d-r4 cpupower
-
- systemd_dounit "${FILESDIR}"/cpupower-frequency-set.service
- systemd_install_serviced "${FILESDIR}"/cpupower-frequency-set.service.conf
-}