summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-02 12:26:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-02 12:29:07 +0200
commit696aac797796455ed50faca69d18a7c67ba49c49 (patch)
tree4a9591d15f47583a8b3855fdcba32f59ba891ac2 /sys-process/numactl
parentsys-process/numactl: Bump to version 2.0.13 (diff)
downloadgentoo-696aac797796455ed50faca69d18a7c67ba49c49.tar.gz
gentoo-696aac797796455ed50faca69d18a7c67ba49c49.tar.bz2
gentoo-696aac797796455ed50faca69d18a7c67ba49c49.zip
sys-process/numactl: Synced live ebuild
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process/numactl')
-rw-r--r--sys-process/numactl/numactl-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-process/numactl/numactl-9999.ebuild b/sys-process/numactl/numactl-9999.ebuild
index 312ab570210b..e38e4a774774 100644
--- a/sys-process/numactl/numactl-9999.ebuild
+++ b/sys-process/numactl/numactl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs multilib-minimal
@@ -41,7 +41,7 @@ multilib_src_compile() {
multilib_src_test() {
if multilib_is_native_abi ; then
- if [ -d /sys/devices/system/node ]; then
+ if [[ -d /sys/devices/system/node ]] ; then
einfo "The only generically safe test is regress2."
einfo "The other test cases require 2 NUMA nodes."
emake regress2
@@ -54,12 +54,12 @@ multilib_src_test() {
multilib_src_install() {
emake DESTDIR="${D}" \
install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
- find "${ED%/}"/usr/ -name libnuma.la -delete || die
+ find "${ED}"/usr/ -type f -name libnuma.la -delete || die
}
multilib_src_install_all() {
local DOCS=( README.md )
einstalldocs
# delete man pages provided by the man-pages package #238805
- rm -r "${ED%/}"/usr/share/man/man[25] || die
+ rm -r "${ED}"/usr/share/man/man[25] || die
}