summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-03 14:38:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-03 14:39:17 +0200
commit253b83b334121939ee2017309356095d080935cf (patch)
tree195504f4611a42f7cc2200b1fb2ee05f9c685a20 /sys-process
parentmedia-libs/libmpdclient: Version bump (v2.15) (diff)
downloadgentoo-253b83b334121939ee2017309356095d080935cf.tar.gz
gentoo-253b83b334121939ee2017309356095d080935cf.tar.bz2
gentoo-253b83b334121939ee2017309356095d080935cf.zip
sys-process/at: Bump to version 3.1.23
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/Manifest1
-rw-r--r--sys-process/at/at-3.1.23.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/sys-process/at/Manifest b/sys-process/at/Manifest
index 1ffc8d52d87f..2fa904fc7b1b 100644
--- a/sys-process/at/Manifest
+++ b/sys-process/at/Manifest
@@ -1,2 +1,3 @@
DIST at_3.1.18.orig.tar.gz 124499 BLAKE2B b7c65d33fea3d3345ec7d1eb82652c787cfa86520bdd8ac0329baad5cd19cf85ffefe695e86480d38833abe131da8e9c2ea8685699bcfe8baafb3e2cfa57502e SHA512 5ec7512663461ffa1922cef0d99c3cc4882defbea7b1ab855b05bb83e9d3817535db73db74413bcc8af005c956032ec3dc7c83ac16fde96bb315094dae654042
DIST at_3.1.20.orig.tar.gz 127666 BLAKE2B 8fd0350859e59e61c72f6c67c174ce05bb9c6cffa77792ded11be43eb24d6d1cf2f9f32719657b937e5a11ba8eabefa0e94d5254f05ab79a3daa40c30af97bd8 SHA512 20a13512a86f988728f590712f5bf8a23f4dc44f4b42521a4dd4783dc1ba7ac2016ee87b4c2c14f2346a5839168a983d99c3195e947014aea3096a3db16d176f
+DIST at_3.1.23.orig.tar.gz 126284 BLAKE2B b2af9dfa4ed87ee93489b98acae6b7eb005d6db7e2401ec7d4d21353af636b232d57e92e4cd6e81f52115aa9d29fadf440809a9d77cb1eb5d40d42ec7fe640b0 SHA512 ee5cf5abf32cf1e89746e427d1cc20005ef49fad47db55512c90042a77e86b2c15f5de029c79573bc86ce4aead6ed2d561b89812510aadbc5763f9288b467cfd
diff --git a/sys-process/at/at-3.1.23.ebuild b/sys-process/at/at-3.1.23.ebuild
new file mode 100644
index 000000000000..66481a8ffd51
--- /dev/null
+++ b/sys-process/at/at-3.1.23.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils flag-o-matic pam user systemd
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="https://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+)
+
+pkg_setup() {
+ # Cannot be moved into pkg_preinst!
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local my_conf=(
+ --sysconfdir=/etc/at
+ --with-jobdir=/var/spool/at/atjobs
+ --with-atspool=/var/spool/at/atspool
+ --with-etcdir=/etc/at
+ --with-daemon_username=at
+ --with-daemon_groupname=at
+ $(usex pam '' --without-pam)
+ $(use_with selinux)
+ )
+ econf ${my_conf[@]}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc8 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${EROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${ED}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+ keepdir /var/spool/at/atspool
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ local atspooldir="${EROOT}/var/spool/at"
+ chown at:at "${atspooldir}/atjobs"
+ chmod 1770 "${atspooldir}/atjobs"
+ chown at:at "${atspooldir}/atjobs/.SEQ"
+ chmod 0600 "${atspooldir}/atjobs/.SEQ"
+ chown at:at "${atspooldir}/atspool"
+ chmod 1770 "${atspooldir}/atspool"
+}