summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-02-09 20:02:46 -0500
committerMike Frysinger <vapier@gentoo.org>2017-02-09 20:48:44 -0500
commit7e61da823863ce1e9b55facc356b043d073f1349 (patch)
tree862852bdd205cb03af2dab087783ae3884d753b8 /sys-process
parentsys-process/audit: set up build env vars #549608 (diff)
downloadgentoo-7e61da823863ce1e9b55facc356b043d073f1349.tar.gz
gentoo-7e61da823863ce1e9b55facc356b043d073f1349.tar.bz2
gentoo-7e61da823863ce1e9b55facc356b043d073f1349.zip
sys-process/audit: use prefix vars for base paths
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/audit-2.6.4.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-process/audit/audit-2.6.4.ebuild b/sys-process/audit/audit-2.6.4.ebuild
index 34c881cdfd1f..0f4ddd8ceb54 100644
--- a/sys-process/audit/audit-2.6.4.ebuild
+++ b/sys-process/audit/audit-2.6.4.ebuild
@@ -76,7 +76,7 @@ src_prepare() {
multilib_src_configure() {
local ECONF_SOURCE=${S}
econf \
- --sbindir=/sbin \
+ --sbindir="${EPREFIX}/sbin" \
--enable-systemd \
--without-python \
--without-python3
@@ -192,9 +192,9 @@ multilib_src_install_all() {
fperms 644 "$(systemd_get_systemunitdir)"/auditd.service # 556436
- [ -f "${D}"/sbin/audisp-remote ] && \
+ [ -f "${ED}"/sbin/audisp-remote ] && \
dodir /usr/sbin && \
- mv "${D}"/{sbin,usr/sbin}/audisp-remote || die
+ mv "${ED}"/{sbin,usr/sbin}/audisp-remote || die
# Gentoo rules
insinto /etc/audit/
@@ -205,7 +205,7 @@ multilib_src_install_all() {
keepdir /var/log/audit/
# Security
- lockdown_perms "${D}"
+ lockdown_perms "${ED}"
prune_libtool_files --modules
}
@@ -216,15 +216,15 @@ pkg_preinst() {
}
pkg_postinst() {
- lockdown_perms "${ROOT}"
+ lockdown_perms "${EROOT}"
# Preserve from the audit-1 series
preserve_old_lib_notify /$(get_libdir)/libaudit.so.0
}
lockdown_perms() {
- # upstream wants these to have restrictive perms
- # should not || die, maybe not all paths exist
- basedir="$1"
+ # Upstream wants these to have restrictive perms.
+ # Should not || die as not all paths may exist.
+ local basedir="$1"
chmod 0750 "${basedir}"/sbin/au{ditctl,report,dispd,ditd,search,trace} 2>/dev/null
chmod 0750 "${basedir}"/var/log/audit/ 2>/dev/null
chmod 0640 "${basedir}"/etc/{audit/,}{auditd.conf,audit.rules*} 2>/dev/null