summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-06-14 22:20:25 +0800
committerYixun Lan <dlan@gentoo.org>2016-06-14 22:21:26 +0800
commitaf6724544b88a1dfbad3dcc14ca932516e299b2d (patch)
tree70eeffe4e49841ad63a1ac4c29c34cd6bad959d7 /sys-process
parentmedia-gfx/wings: Drop alpha keyword (diff)
downloadgentoo-af6724544b88a1dfbad3dcc14ca932516e299b2d.tar.gz
gentoo-af6724544b88a1dfbad3dcc14ca932516e299b2d.tar.bz2
gentoo-af6724544b88a1dfbad3dcc14ca932516e299b2d.zip
sys-process/criu: fixed to not use git cmd
Gentoo-Bug: 580420 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/criu/criu-2.2.ebuild1
-rw-r--r--sys-process/criu/files/2.2/criu-2.2-no-git.patch16
2 files changed, 17 insertions, 0 deletions
diff --git a/sys-process/criu/criu-2.2.ebuild b/sys-process/criu/criu-2.2.ebuild
index c18ed46f68aa..a2bb1740da98 100644
--- a/sys-process/criu/criu-2.2.ebuild
+++ b/sys-process/criu/criu-2.2.ebuild
@@ -38,6 +38,7 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}"/${PV}/${P}-flags.patch
"${FILESDIR}"/${PV}/${P}-makefile.patch
+ "${FILESDIR}"/${PV}/${P}-no-git.patch
"${FILESDIR}"/2.0/${PN}-2.0-automagic-libbsd.patch
"${FILESDIR}"/2.0/${PN}-2.0-sysroot.patch
)
diff --git a/sys-process/criu/files/2.2/criu-2.2-no-git.patch b/sys-process/criu/files/2.2/criu-2.2-no-git.patch
new file mode 100644
index 000000000000..0622225c2905
--- /dev/null
+++ b/sys-process/criu/files/2.2/criu-2.2-no-git.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile b/Makefile
+index 7c85403..20992ed 100644
+--- a/Makefile
++++ b/Makefile
+@@ -179,9 +179,9 @@ test: zdtm
+ # Generating tar requires tag matched CRIU_VERSION.
+ # If not found then simply use GIT's describe with
+ # "v" prefix stripped.
+-head-name := $(shell git tag -l v$(CRIU_VERSION))
++head-name := $(shell if [ -d ".git" ]; then git tag -l v$(CRIU_VERSION); fi)
+ ifeq ($(head-name),)
+- head-name := $(shell git describe)
++ head-name := $(shell if [ -d ".git" ]; then git describe; fi)
+ endif
+ tar-name := $(shell echo $(head-name) | sed -e 's/^v//g')
+ criu-$(tar-name).tar.bz2: