summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-11-04 23:48:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-11-04 23:48:38 +0100
commitb0cfdd8632ebc85620266018b7f1f6d30183cb6e (patch)
tree910da1abd48a1e9ba92f23402c3503d82d45984a /sys-process
parentsys-fs/jmtpfs: Fix media-libs/libmtp dependency (diff)
downloadgentoo-b0cfdd8632ebc85620266018b7f1f6d30183cb6e.tar.gz
gentoo-b0cfdd8632ebc85620266018b7f1f6d30183cb6e.tar.bz2
gentoo-b0cfdd8632ebc85620266018b7f1f6d30183cb6e.zip
sys-process/lsof: remove USE=static
USE=static doesn't work with USE=rpc anymore since tirpc was moved to net-libs/libtirpc: - net-libs/libtirpc[static-libs] is broken: When net-libs/libtirpc was build with USE=kerberos it isn't guaranteed that virtual/krb5 provider was linked statically which is causing problems for lsof when trying to statically link against libtirpc. - getrpcbynumber from print.c is now part of libc. However you cannot statically link against that libc component. Closes: https://bugs.gentoo.org/667272 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/lsof/lsof-4.91.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/sys-process/lsof/lsof-4.91.ebuild b/sys-process/lsof/lsof-4.91.ebuild
index ff937fc558c5..8dd49f00f030 100644
--- a/sys-process/lsof/lsof-4.91.ebuild
+++ b/sys-process/lsof/lsof-4.91.ebuild
@@ -15,7 +15,7 @@ SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
LICENSE="lsof"
SLOT="0"
KEYWORDS="~alpha ~amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples ipv6 rpc selinux static"
+IUSE="examples ipv6 rpc selinux"
RDEPEND="rpc? ( net-libs/libtirpc )
selinux? ( sys-libs/libselinux )"
@@ -62,8 +62,6 @@ target() {
}
src_configure() {
- use static && append-ldflags -static
-
append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
append-cppflags $(usex ipv6 -{D,U}HASIPv6)
[[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX