summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-01-01 21:00:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-01-01 21:01:44 +0100
commitd9c5c2f0541df9a6a61ae93268772b24c71f5f60 (patch)
tree1328f248067195017b324d668d5f513b07e4524d /sys-process
parentgames-fps/industri: EAPI=5; tidy (diff)
downloadgentoo-d9c5c2f0541df9a6a61ae93268772b24c71f5f60.tar.gz
gentoo-d9c5c2f0541df9a6a61ae93268772b24c71f5f60.tar.bz2
gentoo-d9c5c2f0541df9a6a61ae93268772b24c71f5f60.zip
sys-process/at: Bump to version 3.1.18 (bug #568810).
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/at/Manifest1
-rw-r--r--sys-process/at/at-3.1.18.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-process/at/Manifest b/sys-process/at/Manifest
index 9414db555d7d..4dfad89e5aad 100644
--- a/sys-process/at/Manifest
+++ b/sys-process/at/Manifest
@@ -1,2 +1,3 @@
DIST at_3.1.14.orig.tar.gz 122865 SHA256 cd092bf05d29c25b286f55a960ce8b8c3c5beb571d86ed8eb1dfb3b61291b3ae SHA512 06c0e66062a4e96a4a86c7a01d4ec93d47a1a40f7bc0649b3ddb1775b47a2d32d5e6ec9f9f4bdd044ed72e8c327f85128b19f7dc5e467d406d2d106a6952f7b2 WHIRLPOOL 3c6ca09e46531a12eda7f99710cf461f6831c3a1fd48d67b24e631362149b760b4906852b3bd5f6c03cfae6ce0f21eb5bd386ec7f8e3e1ea1cf3d960577a6036
DIST at_3.1.16.orig.tar.gz 123174 SHA256 cb9af59c6a54edce9536ba629841055409d1f89d8ae26494727a97141fb4d5c1 SHA512 d63132536d01153c4b38499b316c8a7980cd47a75b00fb5edc6e41f24345f97b55b20e5801d50f1bde2f337acc7bdb7e318456c241415e7b7bddee7e51e68ad5 WHIRLPOOL 7ad8a15e53afc915d0cf52b1b42d810876538317665e05232a3b898244558cdb76cad727e2479db3437249e3e63dab2c824c30bb94bd28e6f65edbd5848d2e2c
+DIST at_3.1.18.orig.tar.gz 124499 SHA256 dbd5c8cb8edd53ef467363c3af0391c08769f1dbbd4d5002c59a4cd4cac11d52 SHA512 5ec7512663461ffa1922cef0d99c3cc4882defbea7b1ab855b05bb83e9d3817535db73db74413bcc8af005c956032ec3dc7c83ac16fde96bb315094dae654042 WHIRLPOOL ba2c9d09605cc66ce2a01113700d45c3ce37dddbd244928dca836c570450aaf6aceba15c834dca4e844bb27c9a74cc33eac38a1cbe0a1f5bb7c55ee42bd38424
diff --git a/sys-process/at/at-3.1.18.ebuild b/sys-process/at/at-3.1.18.ebuild
new file mode 100644
index 000000000000..30526260caff
--- /dev/null
+++ b/sys-process/at/at-3.1.18.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic pam user systemd
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam selinux"
+
+DEPEND="virtual/mta
+ >=sys-devel/autoconf-2.64
+ sys-devel/bison
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ epatch "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.1.13-getloadavg.patch
+
+ eautoconf
+}
+
+src_configure() {
+ use pam || my_conf="--without-pam"
+ use selinux && my_conf+= "--with-selinux"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf}
+}
+
+src_install() {
+ emake install IROOT="${D}"
+
+ newinitd "${FILESDIR}"/atd.rc8 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${ROOT}/var/spool/at/atjobs/.SEQ"
+ if [ -f "${seq_file}" ] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${D}"/var/spool/at/atjobs/ || die
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ local atspooldir="${ROOT}/var/spool/at"
+ chown at:at "${atspooldir}/atjobs"
+ chmod 1770 "${atspooldir}/atjobs"
+ chown at:at "${atspooldir}/atjobs/.SEQ"
+ chmod 0600 "${atspooldir}/atjobs/.SEQ"
+ chown at:at "${atspooldir}/atspool"
+ chmod 1770 "${atspooldir}/atspool"
+}