summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-06 13:36:45 +0300
committerStefan Strogin <steils@gentoo.org>2019-05-06 14:12:32 +0300
commitde55e57bfe35efd3fc4c83b0d21c73bbb47e30ee (patch)
tree02847125fc6c7a4cd40e0594a7992e763a370679 /sys-process
parentmedia-gfx/gimp: Drop old (diff)
downloadgentoo-de55e57bfe35efd3fc4c83b0d21c73bbb47e30ee.tar.gz
gentoo-de55e57bfe35efd3fc4c83b0d21c73bbb47e30ee.tar.bz2
gentoo-de55e57bfe35efd3fc4c83b0d21c73bbb47e30ee.zip
sys-process/bcron: bump version to 0.11
Mask it temporarily since it depends on masked >=dev-libs/bglibs-2.04. Closes: https://bugs.gentoo.org/670694 Closes: https://github.com/gentoo/gentoo/pull/11903 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/bcron/Manifest1
-rw-r--r--sys-process/bcron/bcron-0.11.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/sys-process/bcron/Manifest b/sys-process/bcron/Manifest
index 2879932b6383..8d7c3fd040c1 100644
--- a/sys-process/bcron/Manifest
+++ b/sys-process/bcron/Manifest
@@ -1 +1,2 @@
DIST bcron-0.10.tar.gz 68314 BLAKE2B faa7204703af18108675ddb2f2e835cdfcc230f03d80a27b66734110c6354c120f1a2e6357c476b27d72e95935c9bfd805f901521087632cb7e1c26d3b59ba98 SHA512 cfc61651a77bedbaa3e6d9b5e5e8fa070883dfaf1cf314fc47b6114575ad4818f22fb5dd52959a0af077c3f30e2e902fed79feb51dc83adc3b36d20cc587f4a1
+DIST bcron-0.11.tar.gz 69950 BLAKE2B 9aaf9e7d8e468a184da97324ccaa6ea557c2d8c3c3557bb90ba9b43b98ac1ddf9bc7d879300394b73c3e5921f9fd7ad8859393076a77a99b9ec3a909e6493a17 SHA512 730e0f4d6fe717ddf89e787d570449f1f7b4b5c44beb2e11b6c88a92177ea02480063f16992f32a13877327b895ca085617dda65de90effd8fb465e578444f05
diff --git a/sys-process/bcron/bcron-0.11.ebuild b/sys-process/bcron/bcron-0.11.ebuild
new file mode 100644
index 000000000000..329c71869b3c
--- /dev/null
+++ b/sys-process/bcron/bcron-0.11.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit cron python-any-r1 toolchain-funcs
+
+DESCRIPTION="A new cron system designed with secure operations in mind by Bruce Guenter"
+HOMEPAGE="https://untroubled.org/bcron/"
+SRC_URI="https://untroubled.org/bcron/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-apps/ucspi-unix
+ sys-process/cronbase
+ virtual/daemontools
+ virtual/mta"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-libs/bglibs-2.04"
+
+CRON_SYSTEM_CRONTAB="yes"
+
+PATCHES=( "${FILESDIR}/${PN}-0.09-fix-socket-permissions.patch" )
+
+src_configure() {
+ echo "${ED}/usr/bin" > conf-bin || die
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -L${EPREFIX}/usr/$(get_libdir)/bglibs" > conf-ld || die
+ echo "${ED}/usr/share/man" > conf-man || die
+}
+
+src_install() {
+ default
+
+ docrontab bcrontab
+ docrondir -o cron -g cron
+ docrondir /var/spool/cron/tmp -o cron -g cron
+
+ keepdir /etc/cron.d
+ dodir /etc/bcron
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+
+ insinto /var/lib/supervise/bcron
+ doins bcron-sched.run
+
+ insinto /var/lib/supervise/bcron/log
+ doins bcron-sched-log.run
+
+ insinto /var/lib/supervise/bcron-spool
+ doins bcron-spool.run
+
+ insinto /var/lib/supervise/bcron-update
+ doins bcron-update.run
+
+ doman bcrontab.1 crontab.5 bcron-update.8 bcron-start.8
+ doman bcron-spool.8 bcron-sched.8 bcron-exec.8
+ dodoc ANNOUNCEMENT NEWS README TODO
+}
+
+pkg_config() {
+ cd "${EROOT}"/var/lib/supervise/bcron || die
+ [[ -e run ]] && ( cp run bcron-sched.run.`date +%Y%m%d%H%M%S` || die )
+ cp bcron-sched.run run || die
+ chmod u+x run || die
+
+ cd "${EROOT}"/var/lib/supervise/bcron/log || die
+ [[ -e run ]] && ( cp run bcron-sched-log.run.`date +%Y%m%d%H%M%S` || die )
+ cp bcron-sched-log.run run || die
+ chmod u+x run || die
+
+ cd "${EROOT}"/var/lib/supervise/bcron-spool || die
+ [[ -e run ]] && ( cp run bcron-spool.run.`date +%Y%m%d%H%M%S` || die )
+ cp bcron-spool.run run || die
+ chmod u+x run || die
+
+ cd "${EROOT}"/var/lib/supervise/bcron-update || die
+ [[ -e run ]] && ( cp run bcron-update.run.`date +%Y%m%d%H%M%S` || die )
+ cp bcron-update.run run || die
+ chmod u+x run || die
+
+ [[ ! -e "${EROOT}"/var/spool/cron/trigger ]] && ( mkfifo "${EROOT}"/var/spool/cron/trigger || die )
+ chown cron:cron "${EROOT}"/var/spool/cron/trigger || die
+ chmod go-rwx "${EROOT}"/var/spool/cron/trigger || die
+}
+
+pkg_postinst() {
+ elog "Run "
+ elog "emerge --config '=${CATEGORY}/${PF}'"
+ elog "to create or update your run files (backups are created) in"
+ elog " /var/lib/supervise/bcron (bcron daemon) and"
+ elog " /var/lib/supervise/bcron-spool (crontab receiver) and"
+ elog " /var/lib/supervise/bcron-update (system crontab updater)"
+
+ cron_pkg_postinst
+}