summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Romanchuk <den4ikkss@gmail.com>2015-11-13 03:41:34 +0200
committerDenis Romanchuk <den4ikkss@gmail.com>2015-11-13 03:47:40 +0200
commite473cee2e988c7ad21053f32211ef824585ca427 (patch)
treed8a6bb4b3ebdeb4272eb5cd306d0ed558754916b /sys-process
parentnet-mail/qprint: Version bump (diff)
downloadgentoo-e473cee2e988c7ad21053f32211ef824585ca427.tar.gz
gentoo-e473cee2e988c7ad21053f32211ef824585ca427.tar.bz2
gentoo-e473cee2e988c7ad21053f32211ef824585ca427.zip
sys-process/atop: systemd support
https://bugs.gentoo.org/show_bug.cgi?id=553310 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/atop/atop-2.2.ebuild4
-rw-r--r--sys-process/atop/files/atop.service11
-rw-r--r--sys-process/atop/files/atopacct.service14
3 files changed, 28 insertions, 1 deletions
diff --git a/sys-process/atop/atop-2.2.ebuild b/sys-process/atop/atop-2.2.ebuild
index baa583b9bbf0..7283c207b5d7 100644
--- a/sys-process/atop/atop-2.2.ebuild
+++ b/sys-process/atop/atop-2.2.ebuild
@@ -4,7 +4,7 @@
EAPI="4"
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs systemd
MY_PV=${PV//_p/-}
MY_P=${PN}-${MY_PV}-3
@@ -43,5 +43,7 @@ src_install() {
rm -f "${ED}"/usr/bin/atop*-${MY_PV}
newinitd "${FILESDIR}"/${PN}.rc-r1 ${PN}
newinitd "${FILESDIR}"/atopacct.rc atopacct
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dounit "${FILESDIR}"/atopacct.service
dodoc atop.cronsysv AUTHOR ChangeLog README
}
diff --git a/sys-process/atop/files/atop.service b/sys-process/atop/files/atop.service
new file mode 100644
index 000000000000..09295b9acd12
--- /dev/null
+++ b/sys-process/atop/files/atop.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Atop advanced performance monitor
+Documentation=man:atop(1)
+
+[Service]
+Type=simple
+ExecStart=/etc/atop/atop.daily
+KillSignal=SIGUSR2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-process/atop/files/atopacct.service b/sys-process/atop/files/atopacct.service
new file mode 100644
index 000000000000..1f51ec41916a
--- /dev/null
+++ b/sys-process/atop/files/atopacct.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Atop process accounting daemon
+Documentation=man:atopacctd(8)
+Conflicts=psacct.service
+After=syslog.target
+Before=atop.service
+
+[Service]
+Type=forking
+PIDFile=/var/run/atopacctd.pid
+ExecStart=/usr/sbin/atopacctd
+
+[Install]
+WantedBy=multi-user.target