summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-27 13:42:17 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-27 13:42:17 +0100
commitfe8dc6b02a1cb193702f25897d27978f2223c11b (patch)
tree285ba5fbc65eff871196ff6657ef26014c710d78 /sys-process
parentnet-analyzer/prometheus-snmp_exporter: Version bump to 0.9.0 (diff)
downloadgentoo-fe8dc6b02a1cb193702f25897d27978f2223c11b.tar.gz
gentoo-fe8dc6b02a1cb193702f25897d27978f2223c11b.tar.bz2
gentoo-fe8dc6b02a1cb193702f25897d27978f2223c11b.zip
sys-process/tini: Version bump to 0.17.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/tini/Manifest1
-rw-r--r--sys-process/tini/tini-0.17.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-process/tini/Manifest b/sys-process/tini/Manifest
index b97fe34541f9..9ac50c9b9888 100644
--- a/sys-process/tini/Manifest
+++ b/sys-process/tini/Manifest
@@ -1,3 +1,4 @@
DIST tini-0.13.2.tar.gz 27828 BLAKE2B 2a983cc654c6553d372ee425d4d153b50522a5e3ee0190262383b650e63c3239f30553504f49925b6e7caaa721fc350bab98e0c87446757d65d4056df58ee4a3 SHA512 117822bf2e45b7cf732bfcd2aa5ea268a189c395f189c03d0e5dcd982872cff29d50adbb1a4d1b85859db4736e932900cfb64a1c487ba271a305146e9677a1d4
DIST tini-0.15.0.tar.gz 29473 BLAKE2B 24aa6ec5f0d24603907d7de816d15d1b6cb6c90a254e5b0f6a52f29ba1dc2ffd7b578b67a97b68230f49b22b7848a677f73db06c659d60eeef48ca46764c961e SHA512 774addddeb2bcefd1db2e4bff7c55bba6c3f4adc41e0b2a647059eef8cc5cc9d4a47b68cb4b89aa4e9e52b85916fe2680dad2a414c82b3c276beea89e3689481
DIST tini-0.16.1.tar.gz 29641 BLAKE2B 637ee17bbf8553b7803dc78cc40ec55ea919ec003005c7f2524322df6cc93a2e4c6fc017fa25c581f50eb17482956ebf37bf49c7796c33d227c7327ca467a906 SHA512 aa0a802c403a07771a2b28a07b97fa2c93d40b5d5be2cba6556c8e7a92e608453010625d0236d26c27bdd2820aed3ad9ca676b70f7fcd5986d7f91eb928d053c
+DIST tini-0.17.0.tar.gz 30881 BLAKE2B 8212bfa56b6ade3b79e1d4d3144b10b98e4daf19e9a9c93f6db44dfea22f80b4c6810619832b339984681d1933d00964f7cfbf516286354141f795d3cb5e745f SHA512 4e59241bd621cd89f9c07dcd7a21754a947c87d3571b06bc5f034c0059a20cbc02d4d22fd08a79633b84fd47980dbf5240e2d2fa382aaf5c32e6003710b7691a
diff --git a/sys-process/tini/tini-0.17.0.ebuild b/sys-process/tini/tini-0.17.0.ebuild
new file mode 100644
index 000000000000..15f145ee4ab7
--- /dev/null
+++ b/sys-process/tini/tini-0.17.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="A tiny but valid init for containers"
+HOMEPAGE="https://github.com/krallin/tini"
+SRC_URI="https://github.com/krallin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+args +static"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # Do not strip binary
+ sed -i -e 's/-Wl,-s")$/")/' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use args || mycmakeargs+=(-DMINIMAL=ON)
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ append-cflags -DPR_SET_CHILD_SUBREAPER=36 -DPR_GET_CHILD_SUBREAPER=37
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use static; then
+ mv "${ED%/}"/usr/bin/{${PN}-static,${PN}} || die
+ else
+ rm "${ED%/}"/usr/bin/${PN}-static || die
+ fi
+}