summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-05-10 10:44:21 -0400
committerMike Gilbert <floppym@gentoo.org>2017-05-10 10:55:24 -0400
commit0a5b19b59d42221c000fe5b4f95cb4a4576d6368 (patch)
tree82bd25da6d09e34601a362752c9d00e299afa94a /virtual
parentapp-crypt/gnupg: Stable for HPPA (bug #617960). (diff)
downloadgentoo-0a5b19b59d42221c000fe5b4f95cb4a4576d6368.tar.gz
gentoo-0a5b19b59d42221c000fe5b4f95cb4a4576d6368.tar.bz2
gentoo-0a5b19b59d42221c000fe5b4f95cb4a4576d6368.zip
virtual/python-dnspython: depend on dev-python/dnspython:0
This will ease the transition as dnspython is stabilized. Bug: https://bugs.gentoo.org/597024 Package-Manager: Portage-2.3.5_p32, Repoman-2.3.2_p62
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-dnspython/python-dnspython-2.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/virtual/python-dnspython/python-dnspython-2.ebuild b/virtual/python-dnspython/python-dnspython-2.ebuild
new file mode 100644
index 000000000000..3c69b4084ea3
--- /dev/null
+++ b/virtual/python-dnspython/python-dnspython-2.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for dnspython, for Python 2 & 3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=dev-python/dnspython-1.15.0:0[${PYTHON_USEDEP}]"