summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-27 09:29:24 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-27 10:26:12 +0100
commitdd62a9f18ee1cbb98a23f4656061223be5993c4d (patch)
tree86c70de56bb98311eca531153488d0dbc853cd56 /virtual
parentdev-python/enum34: Stable under ALLARCHES policy (diff)
downloadgentoo-dd62a9f18ee1cbb98a23f4656061223be5993c4d.tar.gz
gentoo-dd62a9f18ee1cbb98a23f4656061223be5993c4d.tar.bz2
gentoo-dd62a9f18ee1cbb98a23f4656061223be5993c4d.zip
virtual/python-enum34: Add new virtual
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/python-enum34/metadata.xml8
-rw-r--r--virtual/python-enum34/python-enum34-1.ebuild24
2 files changed, 32 insertions, 0 deletions
diff --git a/virtual/python-enum34/metadata.xml b/virtual/python-enum34/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/virtual/python-enum34/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/virtual/python-enum34/python-enum34-1.ebuild b/virtual/python-enum34/python-enum34-1.ebuild
new file mode 100644
index 000000000000..d51d67b21326
--- /dev/null
+++ b/virtual/python-enum34/python-enum34-1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for Python enum34 module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' \
+ 'python2*' python3_3 'pypy*')"