summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-04-13 22:07:16 +0200
committerDavid Seifert <soap@gentoo.org>2016-04-13 22:07:55 +0200
commit760e6538395d889c5481876a772a384fea67fdd5 (patch)
treef1d4abf989d1c1d60892c5be9dd6fc6708a1e7c1 /www-apache/anyterm
parentwww-client/midori: -DUSE_ requires uppercase variable names (diff)
downloadgentoo-760e6538395d889c5481876a772a384fea67fdd5.tar.gz
gentoo-760e6538395d889c5481876a772a384fea67fdd5.tar.bz2
gentoo-760e6538395d889c5481876a772a384fea67fdd5.zip
www-apache/anyterm: Fix boost::system underlinking
Gentoo-Bug: 579522 * EAPI=6 * Remove unnecessary '|| die' on Gentoo helper functions * Add missing 'toolchain-funcs' inherit * Make all patches -p1 compliant for eapply Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apache/anyterm')
-rw-r--r--www-apache/anyterm/anyterm-1.1.29-r1.ebuild27
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch4
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch8
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch4
4 files changed, 24 insertions, 19 deletions
diff --git a/www-apache/anyterm/anyterm-1.1.29-r1.ebuild b/www-apache/anyterm/anyterm-1.1.29-r1.ebuild
index 88c80e5ebda2..a627d7c21bd4 100644
--- a/www-apache/anyterm/anyterm-1.1.29-r1.ebuild
+++ b/www-apache/anyterm/anyterm-1.1.29-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-inherit eutils flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="A terminal anywhere"
HOMEPAGE="http://anyterm.org/"
@@ -26,25 +26,30 @@ PATCHES=(
)
src_prepare() {
- epatch "${PATCHES[@]}"
+ default
+
+ # Fix underlinking issue caused by recent boost versions
+ # depending on boost::system, Gentoo bug #579522
+ sed -e 's/\($(CXX) -o $@ $(LDFLAGS) $(OBJS) $(BLOBS) $(LINK_FLAGS)\)/\1 -lboost_system/' \
+ -i common.mk || die
}
src_compile() {
# this package uses `ld -r -b binary` and thus resulting executable contains
# executable stack
append-ldflags -Wl,-z,noexecstack
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
}
src_install() {
- dosbin anytermd || die
- dodoc CHANGELOG README || die
- doman anytermd.1 || die
- newinitd "${FILESDIR}/anyterm.init.d" anyterm || die
- newconfd "${FILESDIR}/anyterm.conf.d" anyterm || die
+ dosbin anytermd
+ dodoc CHANGELOG README
+ doman anytermd.1
+ newinitd "${FILESDIR}/anyterm.init.d" anyterm
+ newconfd "${FILESDIR}/anyterm.conf.d" anyterm
}
pkg_postinst() {
- elog "To proceed installation, read following:"
+ elog "To proceed with installation, read the following:"
elog "http://anyterm.org/1.1/install.html"
}
diff --git a/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch b/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch
index 25a12e756ab0..ef27604d87e0 100644
--- a/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch
+++ b/www-apache/anyterm/files/anyterm-1.1.28-respect-LDFLAGS.patch
@@ -1,6 +1,6 @@
=== modified file 'common.mk'
---- common.mk 2009-01-24 12:40:55 +0000
-+++ common.mk 2009-01-24 14:02:19 +0000
+--- anyterm-1.1.29/common.mk 2009-01-24 12:40:55 +0000
++++ anyterm-1.1.29/common.mk 2009-01-24 14:02:19 +0000
@@ -71,7 +71,7 @@
OBJS=$(addsuffix .o,$(notdir $(basename $(CC_SRCS))))
diff --git a/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch b/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
index b0648a9e3067..c3357247f4eb 100644
--- a/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
+++ b/www-apache/anyterm/files/anyterm-1.1.29-boost-1.50.patch
@@ -1,7 +1,7 @@
Patch by Arfrever; sent to upstream developer.
---- libpbe/src/parse_http_request.cc
-+++ libpbe/src/parse_http_request.cc
+--- anyterm-1.1.29/libpbe/src/parse_http_request.cc
++++ anyterm-1.1.29/libpbe/src/parse_http_request.cc
@@ -18,11 +18,11 @@
#include "parse_http_request.hh"
@@ -28,8 +28,8 @@ Patch by Arfrever; sent to upstream developer.
namespace pbe {
---- libpbe/src/URI.cc
-+++ libpbe/src/URI.cc
+--- anyterm-1.1.29/libpbe/src/URI.cc
++++ anyterm-1.1.29/libpbe/src/URI.cc
@@ -18,11 +18,11 @@
#include "URI.hh"
diff --git a/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch b/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
index 3809f5aac186..c6fd2e6ad1ae 100644
--- a/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
+++ b/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
@@ -1,5 +1,5 @@
---- libpbe/src/SmtpClient.cc
-+++ libpbe/src/SmtpClient.cc
+--- anyterm-1.1.29/libpbe/src/SmtpClient.cc
++++ anyterm-1.1.29/libpbe/src/SmtpClient.cc
@@ -20,6 +20,7 @@
#include "ip.hh"
#include "select.hh"