summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_auth_xradius
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_auth_xradius')
-rw-r--r--www-apache/mod_auth_xradius/Manifest1
-rw-r--r--www-apache/mod_auth_xradius/files/0.4.6-apache24-api-changes.diff14
-rw-r--r--www-apache/mod_auth_xradius/files/0.4.6-fallback-support.diff31
-rw-r--r--www-apache/mod_auth_xradius/files/0.4.6-obsolete-autotools-syntax.diff19
-rw-r--r--www-apache/mod_auth_xradius/metadata.xml8
-rw-r--r--www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild28
-rw-r--r--www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6.ebuild26
7 files changed, 127 insertions, 0 deletions
diff --git a/www-apache/mod_auth_xradius/Manifest b/www-apache/mod_auth_xradius/Manifest
new file mode 100644
index 000000000000..01a8eea4694c
--- /dev/null
+++ b/www-apache/mod_auth_xradius/Manifest
@@ -0,0 +1 @@
+DIST mod_auth_xradius-0.4.6.tar.bz2 180591 SHA256 ab45f9986e37ca38ef6b8ae765e2baa647529c848c0d21b49abf60cc1e9fbf0b SHA512 7edb26f988f9842825bec1b04f5127816bd53f76d2284d79d87afef2b5d6e9fa8cb8156c3f5543aeb9b013f65295fa70098ade603f00ce6e90b3b0c3e8c41b6a WHIRLPOOL 305cb5d53ee3fe9db7473761a0b4e179ab042e61f88710f7373c8edcb4bde07a6d3cb67f25444ef4bc2e341b6d775fbf59a139532feb18c4f0a0d9488efc7c54
diff --git a/www-apache/mod_auth_xradius/files/0.4.6-apache24-api-changes.diff b/www-apache/mod_auth_xradius/files/0.4.6-apache24-api-changes.diff
new file mode 100644
index 000000000000..a760bd6ce79e
--- /dev/null
+++ b/www-apache/mod_auth_xradius/files/0.4.6-apache24-api-changes.diff
@@ -0,0 +1,14 @@
+--- src/xradius_cache.c.orig 2013-06-10 10:02:53.263071428 +0100
++++ src/xradius_cache.c 2013-06-10 10:03:45.789072216 +0100
+@@ -143,9 +143,9 @@
+ /* Running as Root */
+ if (geteuid() == 0) {
+ /* Allow the configured Apache use to read/write to the DBM */
+- chown(path1, unixd_config.user_id, -1);
++ chown(path1, ap_unixd_config.user_id, -1);
+ if (path2 != NULL) {
+- chown(path2, unixd_config.user_id, -1);
++ chown(path2, ap_unixd_config.user_id, -1);
+ }
+ }
+ #endif
diff --git a/www-apache/mod_auth_xradius/files/0.4.6-fallback-support.diff b/www-apache/mod_auth_xradius/files/0.4.6-fallback-support.diff
new file mode 100644
index 000000000000..da43dc4b2776
--- /dev/null
+++ b/www-apache/mod_auth_xradius/files/0.4.6-fallback-support.diff
@@ -0,0 +1,31 @@
+diff -uNr mod_auth_xradius-0.4.6.ORIG/src/mod_auth_xradius.c mod_auth_xradius-0.4.6/src/mod_auth_xradius.c
+--- mod_auth_xradius-0.4.6.ORIG/src/mod_auth_xradius.c 2014-09-24 13:41:22.990073508 +0100
++++ mod_auth_xradius-0.4.6/src/mod_auth_xradius.c 2014-09-24 13:50:17.204100114 +0100
+@@ -125,15 +125,15 @@
+ rctx = xrad_auth_open();
+
+ /* Loop through the array of RADIUS Servers, adding them to the rctx object */
+- sr = (xrad_server_info *) dc->servers->elts;
+ for (i = 0; i < dc->servers->nelts; ++i) {
+- rc = xrad_add_server(rctx, sr[i].hostname, sr[i].port, sr[i].secret,
++ sr = &(((xrad_server_info*)dc->servers->elts)[i]);
++ rc = xrad_add_server(rctx, sr->hostname, sr->port, sr->secret,
+ dc->timeout, dc->maxtries);
+
+ if (rc != 0) {
+ ap_log_rerror(APLOG_MARK, APLOG_ERR, 0, r,
+ "xradius: Failed to add server '%s:%d': (%d) %s",
+- sr[i].hostname, sr[i].port, rc, xrad_strerror(rctx));
++ sr->hostname, sr->port, rc, xrad_strerror(rctx));
+ goto run_cleanup;
+ }
+ }
+@@ -294,7 +294,7 @@
+ /* To properly use the Pools, this array is allocated from the here, instead of
+ inside the directory configuration creation function. */
+ if (dc->servers == NULL) {
+- dc->servers = apr_array_make(parms->pool, 4, sizeof(xrad_server_info*));
++ dc->servers = apr_array_make(parms->pool, 4, sizeof(xrad_server_info));
+ }
+
+ sr = apr_array_push(dc->servers);
diff --git a/www-apache/mod_auth_xradius/files/0.4.6-obsolete-autotools-syntax.diff b/www-apache/mod_auth_xradius/files/0.4.6-obsolete-autotools-syntax.diff
new file mode 100644
index 000000000000..affb3181485a
--- /dev/null
+++ b/www-apache/mod_auth_xradius/files/0.4.6-obsolete-autotools-syntax.diff
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2013-06-10 09:56:06.905065330 +0100
++++ configure.ac 2013-06-10 09:56:45.968065916 +0100
+@@ -4,6 +4,7 @@
+ AC_PREREQ(2.53)
+ AC_CONFIG_SRCDIR([src/mod_auth_xradius.c])
+ AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_MACRO_DIR([m4])
+ OOO_MAINTAIN_MODE
+ AM_MAINTAINER_MODE
+ AC_CANONICAL_TARGET
+@@ -15,7 +16,7 @@
+ AC_PROG_CC
+ AC_PROG_LD
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
++LT_INIT
+
+ AP_VERSION=2.0.40
+ CHECK_APACHE(,$AP_VERSION,
diff --git a/www-apache/mod_auth_xradius/metadata.xml b/www-apache/mod_auth_xradius/metadata.xml
new file mode 100644
index 000000000000..3ed4669f55a4
--- /dev/null
+++ b/www-apache/mod_auth_xradius/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild
new file mode 100644
index 000000000000..9d9eab775e06
--- /dev/null
+++ b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="Radius authentication for Apache"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_auth_xradius/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="www-servers/apache"
+DOCFILES="README"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-obsolete-autotools-syntax.diff"
+ epatch "${FILESDIR}/${PV}-fallback-support.diff"
+ if has_version ">=www-servers/apache-2.4"; then
+ epatch "${FILESDIR}/${PV}-apache24-api-changes.diff"
+ fi
+ AT_M4DIR="m4" eautoreconf
+}
diff --git a/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6.ebuild b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6.ebuild
new file mode 100644
index 000000000000..bbeb0003438d
--- /dev/null
+++ b/www-apache/mod_auth_xradius/mod_auth_xradius-0.4.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="Radius authentication for Apache"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_auth_xradius/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+DOCFILES="README"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-obsolete-autotools-syntax.diff"
+ if has_version ">=www-servers/apache-2.4"; then
+ epatch "${FILESDIR}/${PV}-apache24-api-changes.diff"
+ fi
+ AT_M4DIR="m4" eautoreconf
+}