summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_ftpd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_ftpd')
-rw-r--r--www-apache/mod_ftpd/Manifest1
-rw-r--r--www-apache/mod_ftpd/files/0.14-r1/45_mod_ftpd.conf51
-rw-r--r--www-apache/mod_ftpd/metadata.xml5
-rw-r--r--www-apache/mod_ftpd/mod_ftpd-0.14-r1.ebuild48
4 files changed, 105 insertions, 0 deletions
diff --git a/www-apache/mod_ftpd/Manifest b/www-apache/mod_ftpd/Manifest
new file mode 100644
index 000000000000..ddea45c3505e
--- /dev/null
+++ b/www-apache/mod_ftpd/Manifest
@@ -0,0 +1 @@
+DIST mod_ftpd-0.14.tar.bz2 330410 SHA256 f36d3b65a5a200fca0c58e453246635e0f8e94c7f870d2b2f1946fa4a8b06d09
diff --git a/www-apache/mod_ftpd/files/0.14-r1/45_mod_ftpd.conf b/www-apache/mod_ftpd/files/0.14-r1/45_mod_ftpd.conf
new file mode 100644
index 000000000000..ab6b39e8ee2a
--- /dev/null
+++ b/www-apache/mod_ftpd/files/0.14-r1/45_mod_ftpd.conf
@@ -0,0 +1,51 @@
+<IfDefine FTPD>
+LoadModule ftpd_module modules/mod_ftpd.so
+
+# Load any of the provider modules here (for user specific chroots)
+#LoadModule ftpd_dbm_module modules/mod_ftpd_dbm.so
+#LoadModule ftpd_dbi_module modules/mod_ftpd_dbi.so
+LoadModule ftpd_default_module modules/mod_ftpd_default.so
+#LoadModule ftpd_fail_module modules/mod_ftpd_fail.so
+
+Listen 21
+<VirtualHost *:21>
+ DocumentRoot /home/ftp
+ FtpProtocol On
+ FtpShowRealPermissions Off
+ FtpAllowActive On
+ FtpPasvMinPort 1024
+ FtpPasvMaxPort 65535
+ FtpLimitOrder default
+ FtpDefaultMaxLogins 100
+
+ <Directory /home/ftp>
+ Anonymous_NoUserID Off
+ Anonymous_MustGiveEmail Off
+ Anonymous_VerifyEmail Off
+ Anonymous_LogEmail Off
+ Anonymous anonymous
+ AuthName ftp
+ AuthType Basic
+ Require valid-user
+ Order allow,deny
+ Allow from all
+ </Directory>
+
+ # only allow changing, retrieving files, and listing on the site
+ <Location />
+ <LimitExcept CHDIR GET LIST>
+ Deny from all
+ </LimitExcept>
+ </Location>
+
+ # allow making directories, listing, chdir, and uploading files.
+ # But don't allow retrieving files.
+ <Location /upload>
+ <LimitExcept LIST PUT MKCOL CHDIR>
+ Deny from all
+ </LimitExcept>
+ </Location>
+</VirtualHost>
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_ftpd/metadata.xml b/www-apache/mod_ftpd/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_ftpd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_ftpd/mod_ftpd-0.14-r1.ebuild b/www-apache/mod_ftpd/mod_ftpd-0.14-r1.ebuild
new file mode 100644
index 000000000000..c4453c5ea902
--- /dev/null
+++ b/www-apache/mod_ftpd/mod_ftpd-0.14-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit apache-module
+
+DESCRIPTION="Apache2 module which provides an FTP server"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_ftpd/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbi gdbm"
+
+DEPEND="dbi? ( dev-db/libdbi )
+ gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
+
+APACHE2_EXECFILES="providers/*/.libs/*.so"
+APACHE2_MOD_CONF="0.14-r1/45_${PN}"
+APACHE2_MOD_DEFINE="FTPD"
+
+DOCFILES="docs/manual.html AUTHORS ChangeLog NOTICE README TODO"
+
+need_apache2_2
+
+src_prepare() {
+ sed -i -e 's/-Wc,-Werror//' Makefile.in providers/*/Makefile.in
+}
+
+src_configure() {
+ local providers="default fail"
+
+ use dbi && providers="dbi ${providers}"
+ use gdbm && providers="dbm ${providers}"
+
+ econf \
+ --with-apxs=${APXS} \
+ --enable-providers="${providers}" \
+ || die "econf failed"
+ }
+
+src_compile() {
+ emake || die "emake failed"
+}