summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-04-25 18:55:18 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-04-25 18:55:35 +0300
commit1df9690a83b2547190d9aced06abafbca1cf4bd9 (patch)
tree6df2b9306b5d95149bbcea464427f477e9b909fd /www-apache/mod_gnutls
parentsys-auth/keystone: removing mitaka (diff)
downloadgentoo-1df9690a83b2547190d9aced06abafbca1cf4bd9.tar.gz
gentoo-1df9690a83b2547190d9aced06abafbca1cf4bd9.tar.bz2
gentoo-1df9690a83b2547190d9aced06abafbca1cf4bd9.zip
www-apache/mod_gnutls: fix gnutls-3.5 + sandbox
Bug: 601228 Bug: 616602 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'www-apache/mod_gnutls')
-rw-r--r--www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild b/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..7a9446eda15f
--- /dev/null
+++ b/www-apache/mod_gnutls/mod_gnutls-0.8.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools apache-module
+
+DESCRIPTION="mod_gnutls uses GnuTLS to provide SSL/TLS encryption for Apache2, similarly to mod_ssl"
+HOMEPAGE="https://mod.gnutls.org/"
+SRC_URI="https://mod.gnutls.org/downloads/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND=">=net-libs/gnutls-3.4.0:="
+DEPEND="${CDEPEND}
+ test? ( app-crypt/monkeysphere )"
+RDEPEND="${CDEPEND}"
+
+# Fails because gpg-agent cannot be accessed
+RESTRICT="test"
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="GNUTLS"
+
+DOCFILES="CHANGELOG NOTICE README"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-apxs="${APXS}" \
+ --disable-strict \
+ ac_cv_path_UNSHARE=no
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ apache-module_src_install
+}