summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-16 00:04:20 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-16 00:04:20 -0400
commite045c30a6e6768dc1d8fafd8e0a66288dfba6f5a (patch)
tree7a86e46da1e5bb0e1fbfe2b7d13a1743847f4884 /www-apache/mod_vhost_ldap
parentx11-plugins/gkrellaclock: new revision to fix CC, CFLAGS, and LDFLAGS. (diff)
downloadgentoo-e045c30a6e6768dc1d8fafd8e0a66288dfba6f5a.tar.gz
gentoo-e045c30a6e6768dc1d8fafd8e0a66288dfba6f5a.tar.bz2
gentoo-e045c30a6e6768dc1d8fafd8e0a66288dfba6f5a.zip
www-apache/mod_vhost_ldap: new revision requiring apache-2.4.x.
Gentoo-Bug: 558918 Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apache/mod_vhost_ldap')
-rw-r--r--www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0-r1.ebuild (renamed from www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild)15
1 files changed, 9 insertions, 6 deletions
diff --git a/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild b/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0-r1.ebuild
index 182a60f7b720..37c0dc8b227a 100644
--- a/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild
+++ b/www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit apache-module depend.apache
+inherit apache-module
DESCRIPTION="Store and configure Apache virtual hosts using LDAP"
HOMEPAGE="http://modvhostldap.alioth.debian.org/"
@@ -20,13 +20,16 @@ APACHE2_MOD_DEFINE="VHOST_LDAP LDAP"
DOCFILES="AUTHORS ChangeLog README"
-# apache[ldap] is needed to run, but not to compile.
-DEPEND=""
-RDEPEND="=www-servers/apache-2*[ldap]"
+# We need apr-util[ldap] and apache to build, but the ldap module for
+# apache is only needed when we try to run the thing.
+DEPEND="dev-libs/apr-util[ldap]"
+RDEPEND="=www-servers/apache-2.4*[ldap]"
-need_apache2
+need_apache2_4
src_prepare() {
+ default
+
sed -i "s/MOD_VHOST_LDAP_VERSION/\"${PV}\"/g" "${PN}.c" || \
die "failed to sed version string"
}