summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-09-10 09:07:16 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-09-10 15:18:38 -0400
commit147405a1394186f7e0181b0526ae6111b8ed80e8 (patch)
tree8e35f2d1b62582088ab7fff39db78e6849cddd2a /www-apache/mpm_itk/mpm_itk-2.4.7_p3.ebuild
parentsci-geosciences/gnome-maps: net-libs/libgfbgraph is a runtime dependency (tha... (diff)
downloadgentoo-147405a1394186f7e0181b0526ae6111b8ed80e8.tar.gz
gentoo-147405a1394186f7e0181b0526ae6111b8ed80e8.tar.bz2
gentoo-147405a1394186f7e0181b0526ae6111b8ed80e8.zip
www-apache/mpm_itk: version bump from v2.4.7-02 to v2.4.7-03.
The new version fixes an SSL/keepalive issue in some browsers. There is a mailing list thread here: http://lists.err.no/pipermail/mpm-itk/2015-August/000889.html The code change is minimal, but the impact is large. The old version has therefore been removed: "Everybody using the 2.4.x series is highly advised to upgrade." Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-apache/mpm_itk/mpm_itk-2.4.7_p3.ebuild')
-rw-r--r--www-apache/mpm_itk/mpm_itk-2.4.7_p3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apache/mpm_itk/mpm_itk-2.4.7_p3.ebuild b/www-apache/mpm_itk/mpm_itk-2.4.7_p3.ebuild
new file mode 100644
index 00000000000..b930c1ea041
--- /dev/null
+++ b/www-apache/mpm_itk/mpm_itk-2.4.7_p3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit apache-module linux-info
+
+MY_PN=${PN/_/-}
+MY_PV=${PV/_p/-0}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Run virtual hosts under separate users/groups"
+HOMEPAGE="http://mpm-itk.sesse.net/"
+SRC_URI="http://mpm-itk.sesse.net/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+# The libcap dependency is automagic, so we require it
+# unconditionally. Reported upstream at,
+#
+# http://lists.err.no/pipermail/mpm-itk/2014-May/000808.html
+#
+#
+# The -threads USE dependency is only reliable as long as we don't
+# support building more than one MPM. See bug #511658.
+#
+DEPEND="sys-libs/libcap
+ >=www-servers/apache-2.4.7[-threads]"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="00_${PN}"
+APACHE2_MOD_DEFINE="MPM_ITK"
+APXS2_ARGS="-c ${PN}.c seccomp.c -lcap"
+need_apache2_4
+
+pkg_setup() {
+ CONFIG_CHECK="~SECCOMP"
+ linux-info_pkg_setup
+
+ local minkv="3.5"
+ if kernel_is -lt ${minkv//./ }; then
+ ewarn "A kernel newer than ${minkv} (with seccomp v2) is needed"
+ ewarn "for LimitUIDRange and LimitGIDRange which we include by"
+ ewarn "default in ${APACHE2_MOD_CONF}.conf."
+ fi
+}