summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-20 12:14:55 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-20 14:28:58 +0000
commit0b2fc6dc4e13ca4a647ccf60848789ae78e07457 (patch)
tree6fe2d21a66f09a57df93a74b066d85ddb3018e1c /www-apache
parentwww-servers/resin: Remove old (diff)
downloadgentoo-0b2fc6dc4e13ca4a647ccf60848789ae78e07457.tar.gz
gentoo-0b2fc6dc4e13ca4a647ccf60848789ae78e07457.tar.bz2
gentoo-0b2fc6dc4e13ca4a647ccf60848789ae78e07457.zip
www-apache/mod_caucho: Version bump to 4.0.47
This ebuild is a rewrite that builds with apxs manually as that is easier. See the ebuild for details but the short version is that Java isn't really needed. Package-Manager: portage-2.2.27
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_caucho/Manifest1
-rw-r--r--www-apache/mod_caucho/mod_caucho-4.0.47.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/www-apache/mod_caucho/Manifest b/www-apache/mod_caucho/Manifest
index cb7fcad096c2..ec19af8df398 100644
--- a/www-apache/mod_caucho/Manifest
+++ b/www-apache/mod_caucho/Manifest
@@ -1,2 +1,3 @@
DIST resin-4.0.26-src.zip 17879008 SHA256 0f7bbea8bd4803d499e1d212a49ac8672500ede80194c4daa12c980ad405e34e SHA512 aae0304664c67667b9abf304ccc3dbaf073be42fcd1dd6aa380d841a34a2a44f0187fa91abe6bf92bf66f394b4b2d4eda7c4c9a55b5cb8a76436446cca3d5512 WHIRLPOOL a536b28cad14219ce5c8aaa791a859d21539176b6f729072483e6278fa9b45de2bb367d6696225c1bafe0148c86c3bb0e46ec81595222160aa742ffdf9d5674c
+DIST resin-4.0.47-src.tar.gz 33022378 SHA256 b97ce450a1059336a4cdf05a16d072128009f7172d028a3b1c2f4eefba4d353a SHA512 c070277c970144a990c45afc86b0626d424618c0ec8122cd7e0e60745339a7f79f5d47483b5a33c24f7fb192e72a2d49823155718b8565a2c273333119279703 WHIRLPOOL 3e703a7c68c0c6cc930277e918656d11a1ff65e5f8bbfccb9dac7ea41b22a7f65b2d28efae8fdbaa181402d0416d87db56f9c974f76f2d5d075db92df8a32f0c
DIST resin-gentoo-patches-4.0.26.tar.bz2 3826 SHA256 adff1fb68e38af68add2e16e3832406a105e14532ee022ad315a955d6d6f4f31 SHA512 fc23c6b82f55b76c063276169e8b6be40ab697dfa07ab8f8f560db33b9c48993526f07190b137406f952e0d1a548cc45f30b6a9ceb4983e2a9eed5de8f4ab5d3 WHIRLPOOL cf7403adcdd0b98fcab2ace7733af7e9fa57361f9e2b2fb128ee8c3a9d787c5e8437f6749889cea1aacbf1ec9b9725647e6737fe4e3d1a98d69d1965c129c2d2
diff --git a/www-apache/mod_caucho/mod_caucho-4.0.47.ebuild b/www-apache/mod_caucho/mod_caucho-4.0.47.ebuild
new file mode 100644
index 000000000000..7ec8139249ec
--- /dev/null
+++ b/www-apache/mod_caucho/mod_caucho-4.0.47.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils apache-module
+
+DESCRIPTION="mod_caucho connects Resin and Apache2"
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+need_apache2_4
+
+APACHE2_MOD_CONF="88_${PN}"
+APACHE2_MOD_DEFINE="CAUCHO"
+
+S="${WORKDIR}/resin-${PV}"
+
+# Although building this manually with apxs is bad, trying to make the
+# build scripts behave is worse. You have to:
+#
+# * Patch configure.ac and Makefile.in to respect flags.
+# * Run eautoreconf (or patch configure and chmod it too).
+# * Inherit java-pkg-2, DEPEND on virtual/jdk, and define pkg_setup just
+# to needlessly satisfy configure or patch out large chunks of it.
+# * Define src_compile to only build the Apache module.
+# * It will still report an implicit declaration of cse_free. If you try
+# to fix this, it will complain that the argument count doesn't match.
+
+APXS2_S="${S}/modules/c/src/apache2"
+APXS2_ARGS="-c -DAPACHE_24 -I../common ${PN}.c ../common/stream.c ../common/config.c ../common/memory.c"
+
+src_configure() {
+ :
+}