summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-06-20 21:22:50 +0200
committerHans de Graaff <graaff@gentoo.org>2018-06-20 21:23:27 +0200
commitc2eab56c0ebc74172d0eec5592ba862ff4244dc6 (patch)
tree06b874f5523ee2fcfbc6289200fc6721e42d437b /www-apache
parentnet-vpn/wireguard: version bump (diff)
downloadgentoo-c2eab56c0ebc74172d0eec5592ba862ff4244dc6.tar.gz
gentoo-c2eab56c0ebc74172d0eec5592ba862ff4244dc6.tar.bz2
gentoo-c2eab56c0ebc74172d0eec5592ba862ff4244dc6.zip
www-apache/passenger: remove vulnerable version
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/Manifest1
-rw-r--r--www-apache/passenger/passenger-5.1.12.ebuild127
2 files changed, 0 insertions, 128 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index 83b775bb13b9..cb051c1816a2 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1,2 +1 @@
-DIST passenger-5.1.12.tar.gz 4245993 BLAKE2B 4f5808bcb373a85fbe2e160d9bd993fdff32a78f5083f5b5ff38112a4d3ca906a18a241cef6744350c0f33ef357dfda7a2cd5af875223a082a19b4e99cba4aeb SHA512 7ecdf0be306a3c4b842c8497861dbc072fc87f5601840678fe1125b77d50e683003b49616397d39b34705c967f604f5193be173c52a9c5ab235ef4e6e43f2f4a
DIST passenger-5.3.2.tar.gz 7039759 BLAKE2B be10b368530b8560d7d93664bbf91711ace0cadb0d1e15a978c0a52311a626ea2e1c6d05e507ef488b384e4a7ccc4b02da35bd5bd5878788b036401e06a33b5f SHA512 97900a0e0de67cc3c3770c291c85c6fe937fceab5632c9832bc5c461d3b4e586a47c9733a1a50a805834f591e5af90651789ed74bf74e0eed4d6ce8084c51967
diff --git a/www-apache/passenger/passenger-5.1.12.ebuild b/www-apache/passenger/passenger-5.1.12.ebuild
deleted file mode 100644
index 81449d020955..000000000000
--- a/www-apache/passenger/passenger-5.1.12.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
- epatch "${FILESDIR}"/${PN}-5.1.1-isnan.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}