summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-07 14:01:05 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-07 14:53:08 +0000
commitd51ff1b1847d8b1960cee3382e4d3becbb73e4b5 (patch)
treee72734d9eb3ff0c1ef5f5522b5df9f4bc4439f2c /www-apache
parentdev-util/pycharm-professional: Restore accidentally removed ebuild (diff)
downloadgentoo-d51ff1b1847d8b1960cee3382e4d3becbb73e4b5.tar.gz
gentoo-d51ff1b1847d8b1960cee3382e4d3becbb73e4b5.tar.bz2
gentoo-d51ff1b1847d8b1960cee3382e4d3becbb73e4b5.zip
www-apache/anyterm: EAPI 5 bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/anyterm/anyterm-1.1.29-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/anyterm/anyterm-1.1.29-r1.ebuild b/www-apache/anyterm/anyterm-1.1.29-r1.ebuild
new file mode 100644
index 000000000000..88c80e5ebda2
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.29-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A terminal anywhere"
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+
+LICENSE="GPL-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/ssh"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.34.1"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.28-respect-LDFLAGS.patch"
+ "${FILESDIR}/${P}-gcc-4.4.patch"
+ "${FILESDIR}/${P}-boost-1.50.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() {
+ # this package uses `ld -r -b binary` and thus resulting executable contains
+ # executable stack
+ append-ldflags -Wl,-z,noexecstack
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ dosbin anytermd || die
+ dodoc CHANGELOG README || die
+ doman anytermd.1 || die
+ newinitd "${FILESDIR}/anyterm.init.d" anyterm || die
+ newconfd "${FILESDIR}/anyterm.conf.d" anyterm || die
+}
+
+pkg_postinst() {
+ elog "To proceed installation, read following:"
+ elog "http://anyterm.org/1.1/install.html"
+}