summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-18 23:50:12 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-18 23:52:23 +0100
commit115428723bffc05c9f37fce4cf2763a1f4f0252c (patch)
tree726ea906c2c966656dc0e8e06e9ecd464b1feb93 /www-apps/grafana-bin/grafana-bin-7.3.3.ebuild
parentprofiles: Mask app-text/kchmviewer for removal (diff)
downloadgentoo-115428723bffc05c9f37fce4cf2763a1f4f0252c.tar.gz
gentoo-115428723bffc05c9f37fce4cf2763a1f4f0252c.tar.bz2
gentoo-115428723bffc05c9f37fce4cf2763a1f4f0252c.zip
www-apps/grafana-bin: bump to v7.3.3
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-apps/grafana-bin/grafana-bin-7.3.3.ebuild')
-rw-r--r--www-apps/grafana-bin/grafana-bin-7.3.3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/www-apps/grafana-bin/grafana-bin-7.3.3.ebuild b/www-apps/grafana-bin/grafana-bin-7.3.3.ebuild
new file mode 100644
index 000000000000..d666b4c9db30
--- /dev/null
+++ b/www-apps/grafana-bin/grafana-bin-7.3.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+MY_PN=${PN/-bin/}
+MY_PV=${PV/_beta/-beta}
+S=${WORKDIR}/${MY_PN}-${MY_PV}
+
+DESCRIPTION="Gorgeous metric viz, dashboards & editors for Graphite, InfluxDB & OpenTSDB"
+HOMEPAGE="https://grafana.org"
+SRC_URI="https://dl.grafana.com/oss/release/grafana-${PV}.linux-amd64.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="acct-group/grafana
+ acct-user/grafana"
+RDEPEND="${DEPEND}
+ media-libs/fontconfig"
+
+QA_PREBUILT="usr/bin/grafana-*"
+QA_PRESTRIPPED=${QA_PREBUILT}
+
+src_install() {
+ keepdir /etc/grafana
+ insinto /etc/grafana
+ newins "${S}"/conf/sample.ini grafana.ini
+ rm "${S}"/conf/sample.ini || die
+
+ # Frontend assets
+ insinto /usr/share/${MY_PN}
+ doins -r public conf
+
+ dobin bin/grafana-cli
+ dobin bin/grafana-server
+
+ newconfd "${FILESDIR}"/grafana.confd grafana
+ newinitd "${FILESDIR}"/grafana.initd.3 grafana
+ systemd_newunit "${FILESDIR}"/grafana.service grafana.service
+
+ keepdir /var/{lib,log}/grafana
+ keepdir /var/lib/grafana/{dashboards,plugins}
+ fowners grafana:grafana /var/{lib,log}/grafana
+ fowners grafana:grafana /var/lib/grafana/{dashboards,plugins}
+ fperms 0750 /var/{lib,log}/grafana
+ fperms 0750 /var/lib/grafana/{dashboards,plugins}
+}
+
+postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+
+ elog "${PN} has built-in log rotation. Please see [log.file] section of"
+ elog "/etc/grafana/grafana.ini for related settings."
+ elog
+ elog "You may add your own custom configuration for app-admin/logrotate if you"
+ elog "wish to use external rotation of logs. In this case, you also need to make"
+ elog "sure the built-in rotation is turned off."
+ fi
+}