summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-11-25 16:58:29 -0500
committerAaron Bauman <bman@gentoo.org>2018-11-25 16:58:29 -0500
commit01a22dc85baa8610837db56d07a5d0ce7b99ad43 (patch)
tree1dae8e2a3f7af636cac61450a67cf0b492516876 /www-apps
parentwww-apps/jekyll-watch: version bump (diff)
downloadgentoo-01a22dc85baa8610837db56d07a5d0ce7b99ad43.tar.gz
gentoo-01a22dc85baa8610837db56d07a5d0ce7b99ad43.tar.bz2
gentoo-01a22dc85baa8610837db56d07a5d0ce7b99ad43.zip
www-apps/jekyll: version bump
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/jekyll/Manifest1
-rw-r--r--www-apps/jekyll/jekyll-3.8.5.ebuild81
-rw-r--r--www-apps/jekyll/metadata.xml4
3 files changed, 86 insertions, 0 deletions
diff --git a/www-apps/jekyll/Manifest b/www-apps/jekyll/Manifest
index 63ad953c9163..8f5042973b24 100644
--- a/www-apps/jekyll/Manifest
+++ b/www-apps/jekyll/Manifest
@@ -1 +1,2 @@
DIST jekyll-3.6.2.tar.gz 740389 BLAKE2B c51e8b1545bfd1bab64c890fdf8d53087e27b3ba2fac07d286d009f1c4b6efb81d3528d239f73a73afa68d1f2d320e816c7015bf385dc9e27cad13d1b4279a50 SHA512 3af17f32098bf1012393d0ad47269ef305138553735ede9c65e461c8f1e1033008a01805c8c96f9aa0f4682f7e68a9cff3eda83a70660a334161ec3d04ce9c72
+DIST jekyll-3.8.5.tar.gz 852490 BLAKE2B 3831c68c8c17b5ca14521988572849b89c8cd37f3fa4d7048adb7e25319f59a31e6174a6d25fb5ba4d33c919389f3a30cb28274cddd29ea644ec5d5aa11875e7 SHA512 2cd6bb8786fa2efc249457f72e9e1a3dc76c61a23d2ed8388fef56f1bd576897260b199edb393eb358cfe3a0b26487e40cc2fd3502c52cc9c828839b9eef624d
diff --git a/www-apps/jekyll/jekyll-3.8.5.ebuild b/www-apps/jekyll/jekyll-3.8.5.ebuild
new file mode 100644
index 000000000000..fdab590b1702
--- /dev/null
+++ b/www-apps/jekyll/jekyll-3.8.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+DESCRIPTION="A simple, blog aware, static site generator"
+HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.4
+ >=dev-ruby/colorator-1.0i
+ >=dev-ruby/em-websocket-0.5
+ >=dev-ruby/i18n-0.7:0.7
+ >=dev-ruby/kramdown-1.14
+ >=dev-ruby/liquid-4.0:4
+ >=dev-ruby/mercenary-0.3.3
+ >=dev-ruby/pathutil-0.9
+ >=dev-ruby/safe_yaml-1.0
+ >=dev-ruby/rouge-1.7:0
+ >=www-apps/jekyll-sass-converter-1.0
+ >=www-apps/jekyll-watch-2.0
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/classifier-reborn-2.1.0
+ dev-ruby/launchy
+ >=dev-ruby/pygments_rb-0.6.0
+ >=dev-ruby/rdiscount-2.0
+ >=dev-ruby/redcarpet-3.2.3
+ dev-ruby/rspec-mocks
+ >=dev-ruby/shoulda-3
+ dev-ruby/test-unit:2
+ www-apps/jekyll-coffeescript
+ )
+"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
+
+ # Drop tests requiring bundler
+ sed -i -e '/bundle_message/d' test/test_new_command.rb || die
+ rm test/test_plugin_manager.rb || die
+
+ # Replace git command in gemspec
+ sed -i 's/git ls-files -z/find -not -type d -print0/' $RUBY_FAKEGEM_GEMSPEC || die
+
+ # FIXMEs:
+ # fails to find fixtures
+ rm test/test_theme.rb || die
+ rm test/test_theme_assets_reader.rb || die
+ sed -i -e '/^ should.*theme/,/^ end$/d' \
+ -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
+ # partially requires 'toml'
+ rm test/test_configuration.rb || die
+ # pygments tests fail because of line numbering
+ sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
+ sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
+}
+
+src_test() {
+ local -x JEKYLL_NO_BUNDLER_REQUIRE=true
+
+ ruby-ng_src_test
+}
diff --git a/www-apps/jekyll/metadata.xml b/www-apps/jekyll/metadata.xml
index 482fe238b680..28188a0391e2 100644
--- a/www-apps/jekyll/metadata.xml
+++ b/www-apps/jekyll/metadata.xml
@@ -5,6 +5,10 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
+ <maintainer type="person">
+ <email>bman@gentoo.org</email>
+ <name>Aaron Bauman</name>
+ </maintainer>
<upstream>
<remote-id type="github">jekyll/jekyll</remote-id>
</upstream>