summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-15 11:37:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-15 11:38:07 -0500
commit2ef666422e30a7c95b30838374f340f0daaba79f (patch)
tree055c40301308e337e46a9be530001185d1f82780 /www-apps
parentapp-emulation/diskimage-builder: 2.25.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-2ef666422e30a7c95b30838374f340f0daaba79f.tar.gz
gentoo-2ef666422e30a7c95b30838374f340f0daaba79f.tar.bz2
gentoo-2ef666422e30a7c95b30838374f340f0daaba79f.zip
www-apps/icingaweb2: 2.7.1 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.7.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index c9b35e260ceb..24f9c84b750b 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,3 +1,4 @@
DIST icingaweb2-2.6.2.tar.gz 8171965 BLAKE2B 2a7ebe4ee84ea311a1e0cac14021db66c0950be74d5984bb055983cd24e0277b43945f0b78ee98edb123412dfd116f875803c988612cd2a8b247f36b7c55f04a SHA512 f5fffbec237b892dbcfeee75a23ba26005cad9b4a1505a4d500bcbd16a8fa29125ed255ee320d3efcd8e43dcfb835244234a5607c562dd8bebe871d1a356b520
DIST icingaweb2-2.6.3.tar.gz 8174959 BLAKE2B 6301a0a509031828b8db886e4ab060596f2239de4e65fe714d98a8f8f73305a1116b534f5c2747ab78446ff39b34fa96fe4eae758942aab2de4946c7cf1cdbcb SHA512 f1d14c7ed87cd677a1c4ac03fd6a54514e7e4693000215e0e1628b0480c738848858546e54866eda3a55b4e7c35b5837ad01dc08b5b76502e24d5a727e271710
DIST icingaweb2-2.7.0.tar.gz 8332315 BLAKE2B 7295208ef1805bd42fd7e173b238c3e939d499e79f674b7b4e4111e33f76bc5dac303216755997808fa7ad043ece3c5c17a158b5531647187135748c0fdcf846 SHA512 37bb15eebfc68bbdf4a20131d279d9696587d265084fcfb9b1c52d52d4f91a2cc04ff1b9ab1a2db5177250ad4baf9e9fbcfafc069645d9aaf297b9667b471994
+DIST icingaweb2-2.7.1.tar.gz 8389123 BLAKE2B f5e469c1fde2b7bc2c22f898a5fb5370ca3788571501f070ed56b32afe8a155aafe70a06bbe09b77cd996725c3e176363aaf0fa885bc843102c56ddfa14da11d SHA512 0300e483e83699a79750dcfd4467a151fcfa95a1eb8735e8d0d8e5d59595ad252b630add3cb462fa4c115b2891f9ab904739ee36d5eb7fcdfb489c9d7658f1b6
diff --git a/www-apps/icingaweb2/icingaweb2-2.7.1.ebuild b/www-apps/icingaweb2/icingaweb2-2.7.1.ebuild
new file mode 100644
index 000000000000..45655f2ebdb1
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.7.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.2[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}