summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-12 17:24:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-12 17:24:53 -0500
commit587d975718504710eb63dc723e09495232af5d66 (patch)
tree49cc86136b936573d6dfe949e9a6bf06c56483b8 /www-apps
parentdev-java/invokebinder: Version bump. (diff)
downloadgentoo-587d975718504710eb63dc723e09495232af5d66.tar.gz
gentoo-587d975718504710eb63dc723e09495232af5d66.tar.bz2
gentoo-587d975718504710eb63dc723e09495232af5d66.zip
www-apps/postfixadmin: bup, has sec fixes too
http://sourceforge.net/p/postfixadmin/discussion/676076/thread/23c07c6e/ Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/postfixadmin/Manifest1
-rw-r--r--www-apps/postfixadmin/postfixadmin-2.3.8.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/www-apps/postfixadmin/Manifest b/www-apps/postfixadmin/Manifest
index bef6e4461f34..37c0d1fc6e1e 100644
--- a/www-apps/postfixadmin/Manifest
+++ b/www-apps/postfixadmin/Manifest
@@ -1 +1,2 @@
DIST postfixadmin-2.3.7.tar.gz 1600662 SHA256 761074e711ab618deda425dc013133b9d5968e0859bb883f10164061fd87006e SHA512 2d217874832bb3e70b200d7ddadcfdc81f0e9d3119bb54070fd645e055e4fd69b8fd9470b88af630a38c4053f4dd132425448b0dbe6525966aa5a4a2d8a1e7d0 WHIRLPOOL 7726aa7157834efcde5ac81f62c92db53b8931e868824cd48e43c541921d18908484291a6c5711a40609ad5e8dded954e8edffbdf0b5673d7cd49d647644bf50
+DIST postfixadmin-2.3.8.tar.gz 1600215 SHA256 8969b3312935c6e94ff17508f5b7e78b65828cd52d371adde3bfd9206597d94a SHA512 96cd4212109a9459344dc017a397b0d6abcb8653c7aae4f40f913e9a49581d7f74bd92500046f8758e195bd24e63a3b2373c461edc96c67fa1d01f91f4f489c6 WHIRLPOOL 4c98ad01a69708abf10970dd437f15945d02c0ccf8e3563051369f39be6b78eba0f7d7bd09b1784e73e65976b7454ae419571b77c0142477790e320710f3de21
diff --git a/www-apps/postfixadmin/postfixadmin-2.3.8.ebuild b/www-apps/postfixadmin/postfixadmin-2.3.8.ebuild
new file mode 100644
index 000000000000..543a347befb1
--- /dev/null
+++ b/www-apps/postfixadmin/postfixadmin-2.3.8.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit user webapp
+
+DESCRIPTION="Web Based Management tool for Postfix style virtual domains and users"
+HOMEPAGE="http://postfixadmin.sourceforge.net"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+mysql postgres +vacation xmlrpc"
+REQUIRED_USE="|| ( mysql postgres )"
+
+DEPEND="vacation? ( dev-perl/DBI
+ virtual/perl-MIME-Base64
+ dev-perl/MIME-EncWords
+ dev-perl/Email-Valid
+ dev-perl/Mail-Sender
+ dev-perl/Log-Dispatch
+ dev-perl/Log-Log4perl
+ dev-perl/MIME-Charset
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg ) )
+ xmlrpc? ( dev-php/ZendFramework[-minimal] )
+ dev-lang/php[unicode,imap,postgres?,xmlrpc?]"
+
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ mysql? ( || ( dev-lang/php[mysqli] dev-lang/php[mysql] ) )"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if use vacation; then
+ enewgroup vacation
+ enewuser vacation -1 -1 -1 vacation
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ if use vacation; then
+ insinto /var/spool/vacation
+ newins VIRTUAL_VACATION/vacation.pl vacation.pl-${SLOT}
+ fowners vacation:vacation /var/spool/vacation/vacation.pl-${SLOT}
+ fperms 770 /var/spool/vacation/vacation.pl-${SLOT}
+ dodoc VIRTUAL_VACATION/FILTER_README
+ newdoc VIRTUAL_VACATION/INSTALL.TXT VIRTUAL_VACATION_INSTALL.TXT
+ rm -r VIRTUAL_VACATION/{vacation.pl,INSTALL.TXT,tests,FILTER_README}
+ fi
+
+ insinto /usr/share/doc/${PF}/
+ doins -r ADDITIONS
+
+ local docs="DOCUMENTS/*.txt INSTALL.TXT CHANGELOG.TXT"
+ dodoc ${docs}
+
+ rm -rf ${docs} DOCUMENTS/ GPL-LICENSE.TXT LICENSE.TXT debian/ tests/ ADDITIONS/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.inc.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.3.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ if use vacation; then
+ # portage does not update owners of directories (feature :)
+ chown vacation:vacation "${ROOT}"/var/spool/vacation/
+ einfo "/var/spool/vacation/vacation.pl symlink was updated to:"
+ einfo "/var/spool/vacation/vacation.pl-${SLOT}"
+ ln -sf "${ROOT}"/var/spool/vacation/vacation.pl{-${SLOT},}
+ fi
+}
+
+pkg_postrm() {
+ # Make sure we don't leave broken vacation.pl symlink
+ find -L "${ROOT}"/var/spool/vacation/ -type l -delete
+ if [[ ! -e "${ROOT}"/var/spool/vacation/vacation.pl ]] &&
+ path_exists "${ROOT}"/var/spool/vacation/vacation.pl-*; then
+ ln -s $(LC_ALL=C ls -1 /var/spool/vacation/vacation.pl-* | tail -n1) \
+ "${ROOT}"/var/spool/vacation/vacation.pl
+ ewarn "/var/spool/vacation/vacation.pl was updated to point on most"
+ ewarn "recent verion, but please, do your own checks"
+ fi
+}