summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2018-09-20 17:18:55 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-10 13:23:31 +0200
commit6689a871ed0f58026a4499c67905a4d6c7b941cd (patch)
treed0f3141db1d91c30f430048d52ad8a45991b46be /www-apps
parentnet-libs/libircclient: Added two openssl fixes from upstream. (diff)
downloadgentoo-6689a871ed0f58026a4499c67905a4d6c7b941cd.tar.gz
gentoo-6689a871ed0f58026a4499c67905a4d6c7b941cd.tar.bz2
gentoo-6689a871ed0f58026a4499c67905a4d6c7b941cd.zip
www-apps/gitea: bump to 1.5.2
Closes: https://bugs.gentoo.org/665638 Closes: https://bugs.gentoo.org/666609 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9928
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.5.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 0cc62b2e77a4..82c77536184c 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1,3 @@
DIST gitea-1.4.1.tar.gz 14978598 BLAKE2B 8fde79291b745750e79c944e7fcf938d2476ddaa386c1277f54bf315831eeb749507e270ca0a8a8351dd8fa60656bb98eb7c478a5c99f2ac20d350b6054339d5 SHA512 3b812bd61215230035ec9241e953f239981d04580d931f379aa550e11d2f7facd56bf70ac9e2d866224d341570a238bcc5c2fa71fd1432cfb95b8c8b703784e6
DIST gitea-1.4.3.tar.gz 14985783 BLAKE2B d2f141a036406c92e7900ce073066ff5024f308c24a2705eb5da229c48a1b6c772d3148222aafd5c0d6608830670badb2a102149f58a134cc32b5175e1ae306e SHA512 24498b418b9ddb14da5568a206e1fa0831c5789e0b64207f413c3b86e2a855052f7af80d3cb80549eaae6944e22af271c00f6308c66487c3be0dccf55a17976a
+DIST gitea-1.5.2.tar.gz 18866286 BLAKE2B a9a31fa6a310dcb6debd9399f234262214021d72adda52af959e6d9d692d5902ff6955a9802bf60212cecb2a0146c4905952d44643aa83e49c645d32541907c2 SHA512 ef91c881b3cb81d79d182b78c95624f24d63e21daa2d6e561fca79edba0ad588fae7c55503f900a8f05c566ed3bff92a9c4385fc7e5c701a80749d2a8c58b599
diff --git a/www-apps/gitea/gitea-1.5.2.ebuild b/www-apps/gitea/gitea-1.5.2.ebuild
new file mode 100644
index 000000000000..ef344def188d
--- /dev/null
+++ b/www-apps/gitea/gitea-1.5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot systemd user
+
+EGO_PN="code.gitea.io/gitea"
+KEYWORDS="~amd64 ~arm"
+
+DESCRIPTION="A painless self-hosted Git service, written in Go"
+HOMEPAGE="https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-go/go-bindata"
+RDEPEND="dev-vcs/git"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitea git
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/\"main.Version.*$/\"main.Version=${PV}\"/"\
+ -e "s/-ldflags '-s/-ldflags '/" src/${EGO_PN}/Makefile || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} generate
+ TAGS="bindata pam sqlite" LDFLAGS="" CGO_LDFLAGS="" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" emake -C src/${EGO_PN} build
+}
+
+src_install() {
+ diropts -m0750 -o git -g git
+ keepdir /var/log/gitea /var/lib/gitea /var/lib/gitea/data
+ pushd src/${EGO_PN} >/dev/null || die
+ dobin gitea
+ insinto /var/lib/gitea/conf
+ newins custom/conf/app.ini.sample app.ini.example
+ popd >/dev/null || die
+ newinitd "${FILESDIR}"/gitea.initd-r1 gitea
+ newconfd "${FILESDIR}"/gitea.confd gitea
+ systemd_dounit "${FILESDIR}/gitea.service"
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/gitea/conf/app.ini" ]]; then
+ elog "No app.ini found, copying initial config over"
+ cp "${FILESDIR}"/app.ini "${EROOT}"/var/lib/gitea/conf/ || die
+ chown git:git /var/lib/gitea/conf/app.ini
+ else
+ elog "app.ini found, please check example file for possible changes"
+ ewarn "Please note that environment variables have been changed:"
+ ewarn "GITEA_WORK_DIR is set to /var/lib/gitea (previous value: unset)"
+ ewarn "GITEA_CUSTOM is set to '\$GITEA_WORK_DIR/custom' (previous: /var/lib/gitea)"
+ fi
+}