summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-18 18:45:42 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-19 07:32:15 +0800
commit781f02a1d863ba97f18214a7127177714cad96db (patch)
treed655a153db3ee59a9b464fe900418ec667fde78a /www-apps
parentmedia-video/smtube: version bump (diff)
downloadgentoo-781f02a1d863ba97f18214a7127177714cad96db.tar.gz
gentoo-781f02a1d863ba97f18214a7127177714cad96db.tar.bz2
gentoo-781f02a1d863ba97f18214a7127177714cad96db.zip
www-apps/icingaweb2-module-pnp4nagios: cosmetic fixes, unify live and release
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1081 on behalf of Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1.ebuild21
-rw-r--r--www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild22
2 files changed, 24 insertions, 19 deletions
diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1.ebuild
index 95062237cd8b..a683de368096 100644
--- a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1.ebuild
+++ b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-1.0.1.ebuild
@@ -1,25 +1,28 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
HOMEPAGE="http://www.icinga.org/"
-MY_PN="icingaweb2-module-pnp"
-SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"
+else
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-KEYWORDS=""
DEPEND=">=net-analyzer/icinga2-2.1.1
>=www-apps/icingaweb2-2.0.0"
RDEPEND="${DEPEND}"
src_install() {
- mkdir -p "${D}/usr/share/icingaweb2/modules/pnp"
- cp -R "${S}"/* "${D}/usr/share/icingaweb2/modules/pnp"
+ insinto "/usr/share/icingaweb2/modules/pnp"
+ doins -r "${S}"/*
}
diff --git a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
index 1f094bb63f87..a683de368096 100644
--- a/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
+++ b/www-apps/icingaweb2-module-pnp4nagios/icingaweb2-module-pnp4nagios-9999.ebuild
@@ -1,26 +1,28 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-
-inherit git-2
+EAPI=6
DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
HOMEPAGE="http://www.icinga.org/"
-EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"
-EGIT_BRANCH="master"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-pnp.git"
+else
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-KEYWORDS=""
DEPEND=">=net-analyzer/icinga2-2.1.1
>=www-apps/icingaweb2-2.0.0"
RDEPEND="${DEPEND}"
src_install() {
- mkdir -p "${D}/usr/share/icingaweb2/modules/pnp"
- cp -R "${S}"/* "${D}/usr/share/icingaweb2/modules/pnp"
+ insinto "/usr/share/icingaweb2/modules/pnp"
+ doins -r "${S}"/*
}