summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-05-24 16:59:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-05-24 16:59:43 -0500
commit7e94620376a3c20e080a6c04c8f4ef34884876c4 (patch)
tree1db2c37ed12798664bb253de11ac9a7231ebcaec /www-apps
parentgames-emulation/mastergear-bin: Bump to 4.3, rename bin to mastergear (diff)
downloadgentoo-7e94620376a3c20e080a6c04c8f4ef34884876c4.tar.gz
gentoo-7e94620376a3c20e080a6c04c8f4ef34884876c4.tar.bz2
gentoo-7e94620376a3c20e080a6c04c8f4ef34884876c4.zip
www-apps/icingaweb2-module-graphite: 1.0.1 bup
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2-module-graphite/Manifest1
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-graphite/Manifest b/www-apps/icingaweb2-module-graphite/Manifest
new file mode 100644
index 000000000000..2713871762cc
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/Manifest
@@ -0,0 +1 @@
+DIST icingaweb2-module-graphite-1.0.1.tar.gz 5988 BLAKE2B 43f98d853643377cc8088e60845c603563ec5f3bee8d1e9f48e884677c7bfbc82da5603e1aae05634616a52bd387c1685bf2605d1abcae0a96cc88dad303dd1c SHA512 594a8d2a141bdf682fa37dc7b677a78f255dfa3d05071878a416b7426ed6355abc2a2864394e333a00c08aba8fd4f898e42c5a49ffeaf689a16de175f6ddb333
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1.ebuild
new file mode 100644
index 000000000000..1722cdeaadb2
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
+HOMEPAGE="http://www.icinga.org/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-pnp"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.0
+ >=www-apps/icingaweb2-2.5.0"
+RDEPEND="${DEPEND}"
+
+PATCHES=()
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/graphite/"
+ doins -r "${S}"/*
+}