summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-08-23 22:58:49 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-08-23 22:58:49 +0100
commit88bb953e4c11c2cd8e895fb086f0b48629f3ce87 (patch)
treefa547855d52ccedcb6ef283579165fdc2f02d3df /www-apps
parentdev-python/jupyter_console: Add missing sphinx themes (diff)
downloadgentoo-88bb953e4c11c2cd8e895fb086f0b48629f3ce87.tar.gz
gentoo-88bb953e4c11c2cd8e895fb086f0b48629f3ce87.tar.bz2
gentoo-88bb953e4c11c2cd8e895fb086f0b48629f3ce87.zip
www-apps/phpBB: Version bump to 3.3.1
Bug: https://bugs.gentoo.org/717716 Bug: https://bugs.gentoo.org/737908 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpBB/Manifest1
-rw-r--r--www-apps/phpBB/phpBB-3.3.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/www-apps/phpBB/Manifest b/www-apps/phpBB/Manifest
index a3587a7253e7..7f3f1e451485 100644
--- a/www-apps/phpBB/Manifest
+++ b/www-apps/phpBB/Manifest
@@ -1 +1,2 @@
DIST phpBB-3.2.8.tar.bz2 4388929 BLAKE2B 8d7b7294a852450400f721cb05d258bb36b88c48133d340292bb2733c4a28da02e3c2038eb269e0549512cc3db286c4e31eb970070edda0493c304185bc303d0 SHA512 467a84917041889eaa7f2e68a0a81d9368f3ee36427883dec7ebd2af72fe21044dbdb08c5a068ab4e67490af2e4b30132db9d3a300382dd5ccc0a54f7ca20a31
+DIST phpBB-3.3.1.tar.bz2 4575916 BLAKE2B 5383da8de81664c99156007eee49d01fe661e74cd6c5970fe07359aa341dc2f54c80d01927b60abf2d48ab830cbe42244bfc5432c758becb4363e334f9298d51 SHA512 b3a24b4f326426c174082362e67d1d6c1b67b3b5daa6a86f3117ef1b458aa70c055bdeaa7caf597f530c2fe4b7f6e569f7f1beacfaf346c83c638dc98d2169cf
diff --git a/www-apps/phpBB/phpBB-3.3.1.ebuild b/www-apps/phpBB/phpBB-3.3.1.ebuild
new file mode 100644
index 000000000000..92e371c9f13e
--- /dev/null
+++ b/www-apps/phpBB/phpBB-3.3.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="An open-source PHP-based bulletin board package"
+HOMEPAGE="https://www.phpbb.com/"
+SRC_URI="https://download.phpbb.com/pub/release/$(ver_cut 1-2)/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+IUSE="ftp gd mssql mysqli postgres sqlite zlib"
+REQUIRED_USE="|| ( mssql mysqli postgres sqlite )"
+
+PHP_RDEPEND="(
+ virtual/httpd-php:@SLOT@
+ dev-lang/php:@SLOT@[ftp?,gd?,json,mssql?,mysqli?,postgres?,sqlite?,xml,zlib?]
+)"
+
+RDEPEND="|| (
+ ${PHP_RDEPEND//@SLOT@/7.4}
+ ${PHP_RDEPEND//@SLOT@/7.3}
+ ${PHP_RDEPEND//@SLOT@/7.2}
+)"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}${PV%%.*}"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+ webapp_hook_script "${FILESDIR}"/permissions
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+
+ # phpBB needs docs together with the other files.
+ dosym ../webapps/${PN}/${SLOT}/htdocs/docs /usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ einfo "phpBB needs a specific web server configuration. For Apache httpd, an"
+ einfo "example configuration is provided via .htaccess files. For lighttpd and"
+ einfo "NGINX, example configuration files can be found in the documentation."
+
+ if use vhosts; then
+ echo
+ ewarn "When installing with webapp-config, specify a group that includes your"
+ ewarn "PHP user with the -g option. It will default to the web server group"
+ ewarn "when running webapp-config as root."
+ fi
+}