summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-05-31 12:45:41 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-06-01 07:07:45 +0000
commite2476d86c53f6dde15c45e16b5dd8d7767cdbaf7 (patch)
treef896a1f81907ff53b879760df3dc55b9a1588b84 /www-apps
parentwww-apps/klaus: remove old (diff)
downloadgentoo-e2476d86c53f6dde15c45e16b5dd8d7767cdbaf7.tar.gz
gentoo-e2476d86c53f6dde15c45e16b5dd8d7767cdbaf7.tar.bz2
gentoo-e2476d86c53f6dde15c45e16b5dd8d7767cdbaf7.zip
www-apps/klaus: add Python 3 support
Package-Manager: portage-2.3.0_rc1 Closes: https://github.com/gentoo/gentoo/pull/1572 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/klaus/klaus-1.0.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/www-apps/klaus/klaus-1.0.1.ebuild b/www-apps/klaus/klaus-1.0.1.ebuild
index 9f7ebd01a9a8..97cbe3ef1b9c 100644
--- a/www-apps/klaus/klaus-1.0.1.ebuild
+++ b/www-apps/klaus/klaus-1.0.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+
EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
@@ -20,7 +21,7 @@ RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.13.0[${PYTHON_USEDEP}]
dev-python/httpauth[${PYTHON_USEDEP}]
dev-python/humanize[${PYTHON_USEDEP}]
ctags? (