summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-07-23 23:18:46 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-07-23 23:19:13 +0000
commitf1f20d8ece199b1318ba269d65563a8adba0467b (patch)
tree6a407148227324dc209c9f498964995549ad221e /www-apps
parentdev-libs/libical: arm64 stable (bug #688490) (diff)
downloadgentoo-f1f20d8ece199b1318ba269d65563a8adba0467b.tar.gz
gentoo-f1f20d8ece199b1318ba269d65563a8adba0467b.tar.bz2
gentoo-f1f20d8ece199b1318ba269d65563a8adba0467b.zip
www-apps/drupal: Security bump to release 8.7.5 - SA-CORE-2019-008.
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.7.5.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index becd150957a3..e3b2cafebd2d 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -4,3 +4,4 @@ DIST drupal-8.7.1.tar.gz 17811529 BLAKE2B 5bdb92a8f6c5675dd311417db526be81149240
DIST drupal-8.7.2.tar.gz 17824323 BLAKE2B 355a4cdbcefe98afd53235bd8546e50efe911a36536aa07e9cb8a86f00dc6b068d0c276e26aee975790ef80ca5030d7464d4b705fa4da9391ce051994a7b850d SHA512 9dc8ca6c431f1d9e50d1c9139efe537815b59bf17b433cdeeb2df5f60ae9a77812f5ca096b5a0aa67bf71344efe60728e46b209609d41fc25065ae58a6bca6af
DIST drupal-8.7.3.tar.gz 17825116 BLAKE2B 961d92526d8d53d1823b01696bacf6bcca7c10ea0057c561a9126d43f0e18ab1b37a5e85b733927793348b8241014b78b4efdf8aaedbf9e6e82caed51df76b64 SHA512 f7b1c0360091f7b14109b6a328663d0006138d3a39855838bfa9ec70d17aa835ffe8fb393e3b54a378bdfd3011f6cfe9e2eae9be5e79c8fc2586bc48b0bd7df2
DIST drupal-8.7.4.tar.gz 17843961 BLAKE2B a07d6acfe41f2f347c8a335f88daa0b19c8016d0d5e533e3038585c59ad9a11cbb68f2352d59cee47c71422a261a3286053784e70cb15614ec061fb6af5d2572 SHA512 85c9e890d34bd5c725a4361030ba7a2ca71e7ff3fd89d92972bd8fcf657047d74760a897e0083dd3f0fc1c4309e87489a8730727804ae20c1be204dfa1c14428
+DIST drupal-8.7.5.tar.gz 17843250 BLAKE2B e68895ae3d097c1bb4269bd77a2180723caa3601322443eaced9e6e157511468b2fe877ee72dafb735c6d7d077c1f3d29e3de6b3624bbcc0f080ec4deb305065 SHA512 f0f34f8314e86b9fa104992fe8f96dfada335f58c5e25c174f44e484c27dd4a2c9f4fb19505ac29636fc7f9548c898fbf497c119ac8dd588e881e7aa373aefde
diff --git a/www-apps/drupal/drupal-8.7.5.ebuild b/www-apps/drupal/drupal-8.7.5.ebuild
new file mode 100644
index 000000000000..a8514d07dfe0
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}