summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-05 17:38:17 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-05 17:40:30 +0200
commite3a8e2f78e1f829ce0192d57da6aa9a9b44efeec (patch)
tree4e2c94875388b443d720a8933282720cfc918f05 /www-client/firefox
parentapp-text/grip: set DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-e3a8e2f78e1f829ce0192d57da6aa9a9b44efeec.tar.gz
gentoo-e3a8e2f78e1f829ce0192d57da6aa9a9b44efeec.tar.bz2
gentoo-e3a8e2f78e1f829ce0192d57da6aa9a9b44efeec.zip
www-client/firefox: disable jemalloc for !elibc_glibc
Closes: https://bugs.gentoo.org/746554 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-78.3.1.ebuild4
-rw-r--r--www-client/firefox/firefox-81.0.1.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-78.3.1.ebuild b/www-client/firefox/firefox-78.3.1.ebuild
index af2a9e59b726..5bb47ac3381a 100644
--- a/www-client/firefox/firefox-78.3.1.ebuild
+++ b/www-client/firefox/firefox-78.3.1.ebuild
@@ -739,6 +739,10 @@ src_configure() {
;;
esac
+ if ! use elibc_glibc ; then
+ mozconfig_add_options_ac '!elibc_glibc' --disable-jemalloc
+ fi
+
# Allow elfhack to work in combination with unstripped binaries
# when they would normally be larger than 2GiB.
append-ldflags "-Wl,--compress-debug-sections=zlib"
diff --git a/www-client/firefox/firefox-81.0.1.ebuild b/www-client/firefox/firefox-81.0.1.ebuild
index b73b187b80cc..51c6d764b99d 100644
--- a/www-client/firefox/firefox-81.0.1.ebuild
+++ b/www-client/firefox/firefox-81.0.1.ebuild
@@ -739,6 +739,10 @@ src_configure() {
;;
esac
+ if ! use elibc_glibc ; then
+ mozconfig_add_options_ac '!elibc_glibc' --disable-jemalloc
+ fi
+
# Allow elfhack to work in combination with unstripped binaries
# when they would normally be larger than 2GiB.
append-ldflags "-Wl,--compress-debug-sections=zlib"