summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/pybugz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/pybugz')
-rw-r--r--www-client/pybugz/Manifest1
-rw-r--r--www-client/pybugz/metadata.xml10
-rw-r--r--www-client/pybugz/pybugz-0.11.1.ebuild37
-rw-r--r--www-client/pybugz/pybugz-9999.ebuild37
4 files changed, 85 insertions, 0 deletions
diff --git a/www-client/pybugz/Manifest b/www-client/pybugz/Manifest
new file mode 100644
index 000000000000..a4ce5bcbc626
--- /dev/null
+++ b/www-client/pybugz/Manifest
@@ -0,0 +1 @@
+DIST pybugz-0.11.1.tar.gz 23787 SHA256 05b2cef8a655ab34d9279e6341d16a803af07958e72320125cb30a3fd6bc8eec SHA512 bc2277a8e900765bf1799e5de65de5df8184bf50b6ca7c78478a9f43ceb78aa66bcb53c3fd89f7b194b13fa14ad162291d559554a8cb073c071104e2b0978c61 WHIRLPOOL cb8f9a36cac6ae7a42e43d6d9489e2593c8ae76153b769bf04f269967e6477e37b1633d30969c4d7c6d0bcd816aff7bd189a1754c06769e3ea0f761eda3c16db
diff --git a/www-client/pybugz/metadata.xml b/www-client/pybugz/metadata.xml
new file mode 100644
index 000000000000..acc1dbc07272
--- /dev/null
+++ b/www-client/pybugz/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">williamh/pybugz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-client/pybugz/pybugz-0.11.1.ebuild b/www-client/pybugz/pybugz-0.11.1.ebuild
new file mode 100644
index 000000000000..ab820262405a
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+PYTHON_REQ_USE="readline(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/williamh/pybugz.git
+ https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+ inherit vcs-snapshot
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="http://www.github.com/williamh/pybugz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+ fi
+}
diff --git a/www-client/pybugz/pybugz-9999.ebuild b/www-client/pybugz/pybugz-9999.ebuild
new file mode 100644
index 000000000000..3434a5c5d9aa
--- /dev/null
+++ b/www-client/pybugz/pybugz-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+PYTHON_REQ_USE="readline(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/williamh/pybugz.git
+ https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+ inherit vcs-snapshot
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="http://www.github.com/williamh/pybugz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+ fi
+}