summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-04-01 21:21:24 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-04-01 21:23:59 +0900
commit7e56ae0eb71a58bb96dd2b942806d294a2b01b22 (patch)
treed21c6d9b86b3069a157eeadd00334a85acd6aad8 /www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
parentwww-client/w3mmee: fix preprocessor error (diff)
downloadgentoo-7e56ae0eb71a58bb96dd2b942806d294a2b01b22.tar.gz
gentoo-7e56ae0eb71a58bb96dd2b942806d294a2b01b22.tar.bz2
gentoo-7e56ae0eb71a58bb96dd2b942806d294a2b01b22.zip
www-client/w3mmee: fix build
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild')
-rw-r--r--www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild80
1 files changed, 40 insertions, 40 deletions
diff --git a/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild b/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
index d49a167a56c2..25c92b189b78 100644
--- a/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
+++ b/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
@@ -1,34 +1,34 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit alternatives eutils toolchain-funcs multilib
+inherit alternatives eutils multilib toolchain-funcs
-IUSE="gpm imlib nls ssl xface"
-
-MY_PV=${PV##*_}-22
-MY_P=${PN}-${MY_PV}
+MY_PV="${PV##*_}-22"
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="A variant of w3m with support for multiple character encodings"
-SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${MY_P}.tar.gz"
HOMEPAGE="http://pub.ks-and-ks.ne.jp/prog/w3mmee/"
+SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${MY_P}.tar.gz"
SLOT="0"
LICENSE="public-domain"
KEYWORDS="amd64 ppc x86"
+IUSE="gpm imlib nls ssl xface"
-DEPEND=">=sys-libs/ncurses-5.2-r3
- >=sys-libs/zlib-1.1.3-r2
- >=dev-libs/boehm-gc-7.2
- dev-lang/perl
+DEPEND=">=dev-libs/boehm-gc-7.2
>=dev-libs/libmoe-1.5.3
- imlib? ( >=media-libs/imlib-1.9.8
- xface? ( media-libs/compface ) )
+ dev-lang/perl
+ >=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ imlib? (
+ >=media-libs/imlib-1.9.8
+ xface? ( media-libs/compface )
+ )
gpm? ( >=sys-libs/gpm-1.19.3-r5 )
nls? ( sys-devel/gettext )
ssl? ( >=dev-libs/openssl-0.9.6b )"
RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
@@ -37,18 +37,19 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-gcc-4.4.patch
epatch "${FILESDIR}"/${PN}-gcc-4.5.patch
epatch "${FILESDIR}"/${PN}-glibc-2.14.patch
+ epatch "${FILESDIR}"/${PN}-rc_name.patch
+ epatch "${FILESDIR}"/${PN}-time.patch
epatch "${FILESDIR}"/${PN}-tinfo.patch
epatch "${FILESDIR}"/${PN}-w3mman.patch
- sed -ie "/^AR=/s:ar:$(tc-getAR):" XMakefile || die
+ sed -i "/^AR=/s:ar:$(tc-getAR):" XMakefile || die
}
src_compile() {
-
local myconf myuse
myuse="use_cookie=y use_ansi_color=y use_history=y
display_code=E system_code=E"
- if use ssl ; then
+ if use ssl; then
myconf="${myconf} --ssl-includedir=/usr/include/openssl
--ssl-libdir=/usr/$(get_libdir)"
myuse="${myuse} use_ssl=y use_ssl_verify=y use_digest_auth=y"
@@ -56,22 +57,22 @@ src_compile() {
myuse="${myuse} use_ssl=n"
fi
- if use gpm ; then
+ if use gpm; then
myuse="${myuse} use_mouse=y"
else
myuse="${myuse} use_mouse=n"
fi
- if use nls ; then
+ if use nls; then
myconf="${myconf} -locale_dir=/usr/share/locale"
else
myconf="${myconf} -locale_dir='(NONE)'"
fi
- if use imlib ; then
+ if use imlib; then
myuse="${myuse} use_image=y use_w3mimg_x11=y
use_w3mimg_fb=n w3mimgdisplay_setuid=n"
- if use xface ; then
+ if use xface; then
myuse="${myuse} use_xface=y"
else
myuse="${myuse} use_xface=n"
@@ -80,50 +81,51 @@ src_compile() {
myuse="${myuse} use_image=n"
fi
- cat >>config.param<<-EOF
+ cat <<-EOF >> config.param
lang=MANY
accept_lang=en
EOF
- env CC=$(tc-getCC) ${myuse} ./configure -nonstop \
+ env CC=$(tc-getCC) ${myuse} ./configure \
+ -nonstop \
-prefix=/usr \
-suffix=mee \
- -auxbindir=/usr/$(get_libdir)/w3mmee \
- -libdir=/usr/$(get_libdir)/w3mmee/cgi-bin \
- -helpdir=/usr/share/w3mmee \
+ -auxbindir=/usr/$(get_libdir)/${PN} \
+ -libdir=/usr/$(get_libdir)/${PN}/cgi-bin \
+ -helpdir=/usr/share/${PN} \
-mandir=/usr/share/man \
- -sysconfdir=/etc/w3mmee \
+ -sysconfdir=/etc/${PN} \
-model=custom \
-libmoe=/usr/$(get_libdir) \
-mb_h=/usr/include/moe \
-mk_btri=/usr/libexec/moe \
- -cflags="${CFLAGS}" -ldflags="${LDFLAGS}" \
- ${myconf} || die
+ -cflags="${CFLAGS}" \
+ -ldflags="${LDFLAGS}" \
+ ${myconf} \
+ || die
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS* README
+ dohtml 00INCOMPATIBLE.html
# w3mman and manpages conflict with those from w3m
- mv "${D}"/usr/share/man/ja/man1/w3m{,mee}.1 || die
mv "${D}"/usr/share/man/man1/w3m{,mee}.1 || die
-
- dodoc ChangeLog NEWS* README
- dohtml 00INCOMPATIBLE.html
+ mv "${D}"/usr/share/man/ja/man1/w3m{,mee}.1 || die
docinto en
- dodoc doc/HISTORY doc/README* doc/keymap.* doc/menu.*
+ dodoc doc/{HISTORY,README,keymap,menu}*
dohtml doc/*
docinto jp
- dodoc doc-jp/HISTORY doc-jp/README* doc-jp/keymap* doc-jp/menu.*
+ dodoc doc-jp/{HISTORY,README,keymap,menu}*
dohtml doc-jp/*
}
pkg_postinst() {
-
w3m_alternatives
einfo
einfo "If you want to render multilingual text, please refer to"
@@ -134,13 +136,11 @@ pkg_postinst() {
}
pkg_postrm() {
-
w3m_alternatives
}
w3m_alternatives() {
-
- if [ ! -f /usr/bin/w3m ] ; then
+ if [[ ! -f /usr/bin/w3m ]]; then
alternatives_makesym /usr/bin/w3m \
/usr/bin/w3m{m17n,mee}
alternatives_makesym /usr/bin/w3mman \